Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
 
主题工具
旧 2008-06-25, 10:58   #91
zdm019812
猛男搞技术
级别:1 | 在线时长:11小时 | 升级还需:1小时
 
zdm019812 的头像
 
注册日期: May 2007
住址: g青海
帖子: 61
现金:142金币
资产:142金币
声望力: 12
声望: 10 zdm019812 向着好的方向发展
声望力: 12
zdm019812 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

飘过

此帖于 2008-06-25 11:04 被 zdm019812 编辑。
帅哥 zdm019812 当前离线  
回复时引用此帖
旧 2008-06-27, 17:42   #92
hanmeng
注册用户
级别:4 | 在线时长:41小时 | 升级还需:4小时级别:4 | 在线时长:41小时 | 升级还需:4小时级别:4 | 在线时长:41小时 | 升级还需:4小时级别:4 | 在线时长:41小时 | 升级还需:4小时
 
注册日期: Oct 2006
住址: 浙江杭州
帖子: 87
现金:206金币
资产:206金币
声望力: 12
声望: 10 hanmeng 向着好的方向发展
声望力: 12
hanmeng 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

DHCP Server建议配置在Windows服务器上
另外HCP在Windows上的机制是广播/单播/广播/单播
但是在CISCO设备上全是广播
hanmeng 当前离线  
回复时引用此帖
旧 2008-07-04, 07:06   #93
westspirit
注册用户
级别:1 | 在线时长:9小时 | 升级还需:3小时
 
注册日期: Jul 2008
住址: 北京
帖子: 12
现金:530金币
资产:530金币
声望力: 0
声望: 10 westspirit 向着好的方向发展
声望力: 0
westspirit 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

引用:
作者: hanmeng 查看帖子
DHCP Server建议配置在Windows服务器上
另外HCP在Windows上的机制是广播/单播/广播/单播
但是在CISCO设备上全是广播
同意。

DHCP Service 最好建立在Host上,就是可以处理3、4层以上的设备上。Windows 可以,其他操作系统也可以。目前最长用的是Linux上的dhcpd.

网络设备一般是处理3层的,非要起service, 估计CPU也吃不消。并且,管理IP都是指定的。
westspirit 当前离线  
回复时引用此帖
旧 2009-05-24, 23:06   #94
missyoulei2006
注册用户
级别:0 | 在线时长:4小时 | 升级还需:1小时
 
注册日期: Aug 2008
住址: beijing
帖子: 1
现金:505金币
资产:505金币
声望力: 0
声望: 10 missyoulei2006 向着好的方向发展
声望力: 0
missyoulei2006 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

我前几天配置了一个871w,router 起DHCP server,无线功能部分做briging。但是无线客户端怎么也拿不到地址,不知道各位有没有碰到过这个问题。
配置如下:
Building configuration...

Current configuration : 4356 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
service sequence-numbers
!
hostname beijing1388
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critica
!
aaa session-id common
clock timezone PCTime 8
!
!
dot11 syslog
!
dot11 ssid wirless
vlan 1
authentication open
guest-mode
!
no ip source-route
ip cef
ip dhcp use vrf connected
ip dhcp use vrf remote
ip dhcp excluded-address 192.168.1.201 192.168.1.254
ip dhcp excluded-address 192.168.1.1 192.168.1.49
!
ip dhcp pool sdm-pool1
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.5.1

!
!
no ip bootp server
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
!
!
archive
log config
hidekeys
!
!
ip tcp synwait-time 10
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description $ES_WAN$$ETH-WAN$
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip route-cache flow
duplex auto
speed auto
pppoe-client dial-pool-number 1
!
interface Dot11Radio0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
!
encryption vlan 1 key 1 size 40bit 0 ******** transmit-key
encryption vlan 1 mode wep mandatory
!
ssid wirless
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
station-role root access-point
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip route-cache flow
bridge-group 1
!
interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username ******** password *************
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 dialer0
!
ip http server
no ip http secure-server
ip nat inside source list inside interface f4 overlo
!
ip access-list standard inside
remark SDM_ACL Category=18
permit 192.168.0.0 0.0.255.255
!
logging trap debugging
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
exec-timeout 0 0
no modem enable
line aux 0
line vty 0 4
password 7 104D000A0618
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end
missyoulei2006 当前离线  
回复时引用此帖
旧 2009-06-12, 10:51   #95
wjbai3
注册用户
级别:2 | 在线时长:15小时 | 升级还需:6小时级别:2 | 在线时长:15小时 | 升级还需:6小时
 
注册日期: Mar 2009
住址: shanghai
帖子: 2
现金:507金币
资产:507金币
声望力: 0
声望: 10 wjbai3 向着好的方向发展
声望力: 0
wjbai3 向着好的方向发展
微笑 回复: Cisco技术讨论第二期――DHCP(整理版)

引用:
作者: bigh 查看帖子
记得以前一个酒店的宽带工程中,客户前期给的项目要求里面有一条就是不论客户端网络设置如何,都能即插即用。不知道怎么能做到。。。
所以想问一下:怎么做到网络中的DHCP能屏蔽掉原来的客户端IP设置,让它强制接受DHCP分配的IP?
就是客户端一接入网络,原有系统的IP参数设置就被屏蔽了,根据网络的DHCP服务重新分配,一拔下网线,屏蔽解除。

查了一下,现在市场上确实有这类功能的产品了,好像有的厂商叫什么智能网关。合勤的一款AP上有这个功能
http://www.zyxel.com.tw/product/mode...0053881&indexc...
安腾网关可以,http://www.amtium.com,是利用ARP病毒原理来欺骗P...你上INTERNET.
wjbai3 当前离线  
回复时引用此帖
旧 2009-06-17, 10:48   #96
lyycarlos
注册用户
级别:1 | 在线时长:11小时 | 升级还需:1小时
 
注册日期: Mar 2008
住址: 上海市
帖子: 2
现金:507金币
资产:507金币
声望力: 0
声望: 10 lyycarlos 向着好的方向发展
声望力: 0
lyycarlos 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

收藏!
lyycarlos 当前离线  
回复时引用此帖
旧 2009-08-19, 13:34   #97
brother-l
注册用户
级别:0 | 在线时长:3小时 | 升级还需:2小时
 
注册日期: Jun 2005
住址: 河北
帖子: 7
现金:19金币
资产:19金币
声望力: 0
声望: 10 brother-l 向着好的方向发展
声望力: 0
brother-l 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

学到很多东西,这种讨论再多一些
brother-l 当前离线  
回复时引用此帖
旧 2009-08-20, 16:30   #98
sichaojun123
军师
级别:0 | 在线时长:1小时 | 升级还需:4小时
 
注册日期: Jul 2007
住址: BEIJING
帖子: 2
现金:10金币
资产:10金币
声望力: 0
声望: 10 sichaojun123 向着好的方向发展
声望力: 0
sichaojun123 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

说的挺细的,很受用!!顶
sichaojun123 当前离线  
回复时引用此帖
旧 2009-08-20, 16:58   #99
sichaojun123
军师
级别:0 | 在线时长:1小时 | 升级还需:4小时
 
注册日期: Jul 2007
住址: BEIJING
帖子: 2
现金:10金币
资产:10金币
声望力: 0
声望: 10 sichaojun123 向着好的方向发展
声望力: 0
sichaojun123 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

说的挺细的,很受用!!顶
sichaojun123 当前离线  
回复时引用此帖
旧 2009-08-23, 16:01   #100
cupxp2
注册用户
级别:0 | 在线时长:0小时 | 升级还需:5小时
 
注册日期: Aug 2009
住址: 厦门市
帖子: 2
现金:508金币
资产:508金币
声望力: 0
声望: 10 cupxp2 向着好的方向发展
声望力: 0
cupxp2 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

谢谢分享,很实用
cupxp2 当前离线  
回复时引用此帖
旧 2009-08-26, 17:25   #101
zhurx
注册用户
级别:5 | 在线时长:57小时 | 升级还需:3小时
 
zhurx 的头像
 
注册日期: Dec 2005
住址: WUXI
帖子: 76
现金:156金币
资产:156金币
声望力: 13
声望: 10 zhurx 向着好的方向发展
声望力: 13
zhurx 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

建议DHCP还是用专门的服务器,思科交换机有此功能,但是不建议用。

URL="http://www.mdshome.com.cn"]无锡马大嫂之家网上商城[/URL]
zhurx 当前离线  
回复时引用此帖
旧 2009-10-17, 01:17   #102
shuolebuyaoku
注册用户
级别:2 | 在线时长:15小时 | 升级还需:6小时级别:2 | 在线时长:15小时 | 升级还需:6小时
 
注册日期: Aug 2009
住址: 西安
帖子: 24
现金:564金币
资产:564金币
声望力: 0
声望: 10 shuolebuyaoku 向着好的方向发展
声望力: 0
shuolebuyaoku 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

我一个距离我比较远的朋友也问过一个问题,他在PC上配DHCPserver,服务器配好后,发现同一网络中的PC能够获取IP,但其他网络却没法获取,最后在与未获取到IP的PC相连的三层交换机上做:ip helper-address ****后,才OK。。。原来PC发送的DHCP request包没法从网关交换机上发出去--
shuolebuyaoku 当前离线  
回复时引用此帖
旧 2010-01-26, 15:58   #103
a_peng
注册用户
级别:0 | 在线时长:4小时 | 升级还需:1小时
 
注册日期: Jan 2010
住址: 秦皇岛
帖子: 1
现金:505金币
资产:505金币
声望力: 0
声望: 10 a_peng 向着好的方向发展
声望力: 0
a_peng 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

引用:
作者: 麦客属马 查看帖子
  
will “ip dhcp excluded-address 10.0.0.1 10.0.0.5” 10.0.0.1 10.0.0.5 is “10.0.0.1 to 10.0.0.5”or 10.0.0.1 and 10.0.0.5 ? thank you very much
a_peng 当前离线  
回复时引用此帖
旧 2010-08-15, 11:25   #104
cx白菜
注册用户
级别:1 | 在线时长:5小时 | 升级还需:7小时
 
注册日期: Aug 2010
住址: 湖北
帖子: 2
现金:1金币
资产:1金币
声望力: 0
声望: 10 cx白菜 向着好的方向发展
声望力: 0
cx白菜 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

还在研究中
cx白菜 当前离线  
回复时引用此帖
旧 2010-10-08, 16:57   #105
huojp
注册用户
级别:0 | 在线时长:4小时 | 升级还需:1小时
 
注册日期: Oct 2010
帖子: 1
现金:5金币
资产:5金币
声望力: 0
声望: 10 huojp 向着好的方向发展
声望力: 0
huojp 向着好的方向发展
回复: Cisco技术讨论第二期――DHCP(整理版)

xue xi xuexi
帅哥 huojp 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 22:21


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号