Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
 
主题工具
旧 2006-07-10, 22:18   #106
冰封的火焰
注册用户
级别:1 | 在线时长:6小时 | 升级还需:6小时
 
注册日期: Jan 2005
住址: 武汉
帖子: 9
现金:18金币
资产:18金币
声望力: 0
声望: 10 冰封的火焰 向着好的方向发展
声望力: 0
冰封的火焰 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

引用:
作者: xiaoyue7810
最好能用RADWARE LINKPROOF。路由器不用。
终极解决方案,Radware公司的链路流量管理应用交换机(也称作链路流量负载均衡器)LinkProof ... 配置与多个ISP的冗余Internet连接
冰封的火焰 当前离线  
回复时引用此帖
旧 2006-07-11, 17:14   #107
id15153030
注册用户
级别:1 | 在线时长:8小时 | 升级还需:4小时
 
注册日期: Apr 2005
住址: 武汉
帖子: 8
现金:31金币
资产:31金币
声望力: 0
声望: 10 id15153030 向着好的方向发展
声望力: 0
id15153030 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

关注
id15153030 当前离线  
回复时引用此帖
旧 2006-07-12, 10:37   #108
工作需要
注册用户
级别:2 | 在线时长:16小时 | 升级还需:5小时级别:2 | 在线时长:16小时 | 升级还需:5小时
 
工作需要 的头像
 
注册日期: May 2005
住址: 唐都
帖子: 59
现金:153金币
资产:153金币
声望力: 14
声望: 10 工作需要 向着好的方向发展
声望力: 14
工作需要 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

顶上去,我现在也在考虑这个问题,不过网络拓扑与楼主的有区别,我们是两台7304分别采用电信2M和联通2M并分别上联到省中心的两台7507上,7304下面是两台3550交换机,主要数据流量是业务数据流量和OA数据流量,现在在7304和7507上采用的是EIGRP+QOS的方法实现了业务和OA的数据分流,但是没有实现广域网线路的互为备份,现在要实现电信2M和联通2M的互为备份,所以也正在关注楼主的这个帖子。
帅哥 工作需要 当前离线  
回复时引用此帖
旧 2006-07-13, 12:35   #109
jinxl
唯我独尊
级别:7 | 在线时长:86小时 | 升级还需:10小时级别:7 | 在线时长:86小时 | 升级还需:10小时级别:7 | 在线时长:86小时 | 升级还需:10小时
 
jinxl 的头像
 
注册日期: Nov 2003
住址: anhui
帖子: 167
现金:407金币
资产:407金币
声望力: 15
声望: 10 jinxl 向着好的方向发展
声望力: 15
jinxl 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

实现比较困难,且耗资源。
卖一台Hisen3010-4000的防火墙+多接入模块不就OK!
负载均衡,又省钱。有安全,基于NP架构。
www.hisencyber.com
025-83493823

一个人的深切期望不但可以创造自己的机会,甚至可以创造自己的天才!
帅哥 jinxl 当前离线  
回复时引用此帖
旧 2006-07-18, 09:26   #110
cdair
注册用户
级别:7 | 在线时长:88小时 | 升级还需:8小时级别:7 | 在线时长:88小时 | 升级还需:8小时级别:7 | 在线时长:88小时 | 升级还需:8小时
 
注册日期: Jun 2006
住址: 上海
帖子: 28
现金:77金币
资产:77金币
声望力: 0
声望: 10 cdair 向着好的方向发展
声望力: 0
cdair 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

PIX开透明;

65交换机做路由策略:
G0/0:10.10.0.10
G0/1:10.11.0.10
ip access-list 110 permit 192.168.1.0 0.0.0.255 any ##(vlan 1)
ip access-list 120 permit 192.168.2.0 0.0.0.255 any ##(vlan 2)
route-map filter 1 permit 10
match ip interface e0
match ip address 110
set ip next-hop 10.10.0.1
route-map filter 1 permit 20
match ip interface e1
match ip address 120
set ip next-hop 10.11.0.1
route-map filter 1 permit 30

R1,R2开HSRP
r1:

interface Ethernet0.1
ip add 10.10.0.3
standby 150 ip 10.10.0.1
standby 150 priority 110
standby 150 preempt
standby track (电信)

interface Ethernet0.2
ip add 10.11.0.4
standby 120 ip 10.11.0.1
standby 120 priority 100
standby 120 preempt

r2:

interface Ethernet0.1
ip add 10.11.0.4
standby 120 ip 10.11.0.1
standby 120 priority 110
standby 120 preempt
standby track (网通)

interface Ethernet0.2
ip add 10.10.0.4
standby 150 ip 10.10.0.1
standby 150 priority 100
standby 150 preempt

R1/2开NAT~大体应该可以了~正常情况分流,当一台路由器DOWN或外网DOWN的话,通过子端口还是可以切换~

没实际做~大家讨论

此帖于 2006-07-18 16:44 被 cdair 编辑。
cdair 当前离线  
回复时引用此帖
旧 2006-07-21, 10:44   #111
lunna163
注册用户
级别:0 | 在线时长:2小时 | 升级还需:3小时
 
注册日期: Jul 2005
住址: hubei
帖子: 7
现金:22金币
资产:22金币
声望力: 0
声望: 10 lunna163 向着好的方向发展
声望力: 0
lunna163 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

做负载均衡好些,主备不好!!!!!!
lunna163 当前离线  
回复时引用此帖
旧 2006-07-21, 10:46   #112
lunna163
注册用户
级别:0 | 在线时长:2小时 | 升级还需:3小时
 
注册日期: Jul 2005
住址: hubei
帖子: 7
现金:22金币
资产:22金币
声望力: 0
声望: 10 lunna163 向着好的方向发展
声望力: 0
lunna163 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

dddddddddd,为什么NET130怎么慢????//
lunna163 当前离线  
回复时引用此帖
旧 2006-07-25, 11:12   #113
yelangdy
注册用户
级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时
 
注册日期: Jun 2005
住址: 北京
帖子: 116
现金:231金币
资产:231金币
声望力: 14
声望: 10 yelangdy 向着好的方向发展
声望力: 14
yelangdy 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

最近好忙啊,都没时间来看看,抽空走走!!
怎么这个问题还没有一个比较好的解决方案呢!!
还在关注中!!
谢谢大家了!!

有人说用负载均衡设备,这个我也知道,我公司就卖这些东东!!呵呵

我只是想把这个当作一个纯技术性的问题,看看cisco能不能在不借助与其他
产品而解决。哪怕是不很理想的,起码它也有解决的方案啊!!

搞技术!!
yelangdy 当前离线  
回复时引用此帖
旧 2006-07-27, 09:08   #114
woshiwei201
注册用户
级别:0 | 在线时长:1小时 | 升级还需:4小时
 
注册日期: Jul 2006
住址: 武汉
帖子: 13
现金:20金币
资产:20金币
声望力: 0
声望: 10 woshiwei201 向着好的方向发展
声望力: 0
woshiwei201 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

看晕了
woshiwei201 当前离线  
回复时引用此帖
旧 2006-07-27, 16:43   #115
chinadzxm
注册用户
级别:1 | 在线时长:9小时 | 升级还需:3小时
 
注册日期: Jul 2006
住址: 四川成都
帖子: 39
现金:91金币
资产:91金币
声望力: 0
声望: 10 chinadzxm 向着好的方向发展
声望力: 0
chinadzxm 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

静态路由加后缀 可以不
chinadzxm 当前离线  
回复时引用此帖
旧 2006-08-02, 11:10   #116
hball
注册用户
级别:1 | 在线时长:8小时 | 升级还需:4小时
 
注册日期: Aug 2006
住址: GZ
帖子: 56
现金:112金币
资产:112金币
声望力: 13
声望: 10 hball 向着好的方向发展
声望力: 13
hball 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

设两条静态路由,带权值的那一种,绝对可以,我也没有看你的环境,也没看你的设备,但是静态路由用好了,这些问题都不是问题,唯一就是麻烦一点.
hball 当前离线  
回复时引用此帖
旧 2006-08-03, 00:43   #117
jojo2002
注册用户
级别:10 | 在线时长:153小时 | 升级还需:12小时级别:10 | 在线时长:153小时 | 升级还需:12小时
 
jojo2002 的头像
 
注册日期: Jul 2006
住址: 北京
帖子: 249
现金:401金币
资产:401金币
声望力: 15
声望: 250 jojo2002 即将成功的新星jojo2002 即将成功的新星jojo2002 即将成功的新星
声望力: 15
jojo2002 即将成功的新星jojo2002 即将成功的新星jojo2002 即将成功的新星
回复: 【求助】双出口+策略路由+链路互备

路过
美女 jojo2002 当前离线  
回复时引用此帖
旧 2006-08-05, 23:54   #118
winjieadminczwj
注册用户
级别:2 | 在线时长:17小时 | 升级还需:4小时级别:2 | 在线时长:17小时 | 升级还需:4小时
 
注册日期: Jan 2006
住址: 北京
帖子: 10
现金:20金币
资产:20金币
声望力: 0
声望: 10 winjieadminczwj 向着好的方向发展
声望力: 0
winjieadminczwj 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

把完整的拓朴图给我画出来 功能要求 和IP归化,我给你把配置给搞出来
发到我邮箱cz_wj_18@163.com

在一个路由器作双线分流和相互备份,这是真实的环境,以测试成功,当时是一个7204的路由器,内存太小,思科在NAT 这块不是很理想,后来,这实现以后,就不用了,太耗资源

ip sla monitor 1
type echo protocol ipIcmpEcho 172.168.0.1
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho 10.1.2.1
ip sla monitor schedule 2 life forever start-time now

!
track 121 rtr 1 reachability
!
track 122 rtr 2 reachability
!
class-map match-all bittorrent
!
!
!
interface FastEthernet1/0
description connect to dianxin
ip address 172.168.0.2 255.255.255.252
no ip proxy-arp
ip nat outside
ip virtual-reassembly
duplex full
!
interface FastEthernet2/0
description connect to neiwang
ip address 220.231.47.1 255.255.255.0 secondary
ip address 60.194.115.254 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
ip policy route-map NEXTHOP
duplex full
!
interface FastEthernet4/0
description connect to wangtong
ip address 10.1.2.146 255.255.255.0
no ip proxy-arp
ip nat outside
ip virtual-reassembly
duplex full
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.168.0.1
ip route 0.0.0.0 0.0.0.0 10.1.2.1
!
no ip http server
!
ip nat pool dianxin 60.194.115.3 60.194.115.3 prefix-length 24
ip nat pool wangtong 220.231.47.3 220.231.47.3 prefix-length 24
ip nat inside source route-map dianxin pool dianxin
ip nat inside source route-map wangtong pool wangtong

access-list 10 permit 60.194.115.0 0.0.0.255
access-list 11 deny 60.194.115.0 0.0.0.255
access-list 11 permit 220.231.47.0 0.0.0.255
access-list 20 permit 220.231.47.0 0.0.0.255
access-list 21 deny 220.231.47.0 0.0.0.255
access-list 21 permit 60.194.115.0 0.0.0.255
access-list 111 permit ip any host 211.99.141.193
snmp-server community yg RW
no cdp run
!
route-map wangtong permit 10
match ip address 21
match interface FastEthernet4/0
!
route-map NEXTHOP permit 10
match ip address 10
set ip next-hop verify-availability 172.168.0.1 10 track 121
set ip next-hop 10.1.2.1
!
route-map NEXTHOP permit 20
match ip address 20
set ip next-hop verify-availability 10.1.2.1 20 track 122
set ip next-hop 172.168.0.1
!
route-map dianxin permit 10
match ip address 11
match interface FastEthernet1/0
!
!

ygjt#

此帖于 2006-08-05 23:56 被 winjieadminczwj 编辑。
winjieadminczwj 当前离线  
回复时引用此帖
旧 2006-08-07, 21:27   #119
nameydk
半桶水
级别:4 | 在线时长:35小时 | 升级还需:10小时级别:4 | 在线时长:35小时 | 升级还需:10小时级别:4 | 在线时长:35小时 | 升级还需:10小时级别:4 | 在线时长:35小时 | 升级还需:10小时
 
注册日期: Mar 2005
住址: 新化
帖子: 78
现金:153金币
资产:153金币
声望力: 14
声望: 10 nameydk 向着好的方向发展
声望力: 14
nameydk 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

引用:
作者: cdair
PIX开透明;

65交换机做路由策略:
G0/0:10.10.0.10
G0/1:10.11.0.10
ip access-list 110 permit 192.168.1.0 0.0.0.255 any ##(vlan 1)
ip access-list 120 permit 192.168.2.0 0.0.0.255 any ##(vlan 2)
route-map filter 1 permit 10
match ip interface e0
match ip address 110
set ip next-hop 10.10.0.1...

我个人赞同这个方案,主要是要看pix能不能开透明,如果不能那可不可以在pix上做策略路由~~~~~~~~~~~
nameydk 当前离线  
回复时引用此帖
旧 2006-08-11, 20:36   #120
cjufo954118
注册用户
级别:4 | 在线时长:33小时 | 升级还需:12小时级别:4 | 在线时长:33小时 | 升级还需:12小时级别:4 | 在线时长:33小时 | 升级还需:12小时级别:4 | 在线时长:33小时 | 升级还需:12小时
 
注册日期: Jan 2005
住址: dfdf
帖子: 44
现金:90金币
资产:90金币
声望力: 0
声望: 10 cjufo954118 向着好的方向发展
声望力: 0
cjufo954118 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

liuxuewu21 先生说的对,他使用 的本地策略,可以在放火墙做,在接口下使用IP POLICY ROUTER-MAP命令,不过要看放火墙的性能而定。
cjufo954118 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 02:25


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号