Cisco网络技术论坛

返回   Cisco网络技术论坛 > 综合区 > 其他计算机类认证考试 > ITAA认证

发表新主题 回复
 
主题工具
旧 2007-11-21, 11:30   #1
itaa_fan
版主
级别:4 | 在线时长:44小时 | 升级还需:1小时级别:4 | 在线时长:44小时 | 升级还需:1小时级别:4 | 在线时长:44小时 | 升级还需:1小时级别:4 | 在线时长:44小时 | 升级还需:1小时
 
itaa_fan 的头像
 
注册日期: Apr 2007
住址: 天津
帖子: 82
积分:11
精华:11
现金:1317金币
资产:1317金币
声望力: 12
声望: 21 itaa_fan 向着好的方向发展
声望力: 12
itaa_fan 向着好的方向发展
ISIS路由泄露(简化)及多L1区域运行在同一路由器


|
  |
  r1-------|-----r2-----r4
  | | /
  | | / 
  | | /
 | r5

r1#interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip router isis
interface Serial1/1
ip address 12.1.1.1 255.255.255.0
ip router isis
router isis
net 01.0000.0000.0001.00
is-type level-2-only


r2#interface FastEthernet0/0
ip address 25.1.1.2 255.255.255.0
ip router isis
interface Serial1/0
ip address 12.1.1.2 255.255.255.0
ip router isis
interface Serial1/1
ip address 24.1.1.2 255.255.255.0
ip router isis
router isis
net 02.0000.0000.0002.00


r4#
interface Serial1/0
ip address 24.1.1.4 255.255.255.0
ip router isis
interface Serial1/1
ip address 45.1.1.4 255.255.255.0
ip router isis
router isis
net 02.0000.0000.0004.00
is-type level-1


r5#
interface FastEthernet0/0
ip address 25.1.1.5 255.255.255.0
ip router isis
interface Serial1/0
ip address 45.1.1.5 255.255.255.0
ip router isis
router isis
net 02.0000.0000.0005.00


不做泄露,r4将负载均衡,就是一半流量通过r2,一半通过r5
r4#traceroute 1.1.1.1
Type escape sequence to abort.
Tracing the route to 1.1.1.1
1 24.1.1.2 148 msec
45.1.1.5 104 msec
24.1.1.2 92 msec
2 25.1.1.2 84 msec
12.1.1.1 84 msec
25.1.1.2 96 msec

很明显通过r2去是最近的,在r2上做泄露,将1.1.1.0 的L2 的路由通告给r4

泄露路由需要两步:一.建立包含要泄露的路由的列表 二.在路由进程下重分发

r2(config)#access-list 100 permit ip 1.1.1.0 0.0.0.255 any
r2(config-router)#redistribute isis ip level-2 into level-1 distribute-list 100


r4就会直接走r2了
r4#traceroute 1.1.1.1
Type escape sequence to abort.
Tracing the route to 1.1.1.1
1 24.1.1.2 64 msec 168 msec 288 msec
2 12.1.1.1 236 msec 140 msec *

r4#sho ip route
i ia 1.1.1.0 [115/158] via 24.1.1.2, Serial1/0
ia表示是泄露来的




接下来我们做一台路由器运行多个L1区域的实验  
r2#
router isis 1
net 01.0000.0000.0002.00
is-type level-1
并将与r1相连的接口运行新增加的进程
interface Serial1/0
ip address 12.1.1.2 255.255.255.0
ip router isis 1

r2#sho clns is-neighbors
Area null:
System Id Interface State Type Priority Circuit Id Format
r5 Fa0/0 Up L1L2 64/64 r5.01 Phase V
r4 Se1/1 Up L1 0 00 Phase V
Area 1:
System Id Interface State Type Priority Circuit Id Format
r1 Se1/0 Up IS 0 00 Phase V

看到的关系是IS,这时r2建立是L1,r1是L2,不能建立邻接关系

将r1改为L1/2
r1(config-router)#is-type level-1-2

r2#sho clns is-neighbors


Area 1:
System Id Interface State Type Priority Circuit Id Format
r1 Se1/0 Up L1 0 00 Phase V

r1#sho clns is-neighbors
System Id Interface State Type Priority Circuit Id Format
r2 Se1/1 Up L1 0 00 Phase V
r1,r2只形成L1的邻接,那么我们只要把r1设为L1就可以了
r1(config-router)#is-type level-1

r1#sho ip ro
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Serial1/1
i*L1 0.0.0.0/0 [115/10] via 12.1.1.2, Serial1/1

通过默认路由到达区域二的其他地址,减小了数据库,以下是没有在r2配置区域1,并且r1为L1/2路由器的时候,r1的数据库

r1#sho isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r1.00-00 * 0x0000000A 0x0D09 1189 1/0/0
r2.00-00 0x0000000D 0x8285 939 1/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r1.00-00 * 0x00000001 0xF39A 1184 0/0/0
r2.00-00 0x0000001E 0x1709 1182 0/0/0
r5.00-00 0x0000000D 0xEBB4 1183 0/0/0
r5.01-00 0x00000007 0x2D9F 413 0/0/0

是配了以后r1的数据库
r1#sho isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r1.00-00 * 0x0000000D 0xFC20 1195 0/0/0
r2.00-00 0x0000000E 0x8086 1186 1/0/0


-QQ:837657958
记着常和我联系哦!

http://wpa.qq.com/pa?p=1:837657958:13有事点这找我
itaa_fan 当前离线  
回复时引用此帖
旧 2012-06-12, 21:23   #2
rtyfgh
注册用户
级别:0 | 在线时长:1小时 | 升级还需:4小时
 
注册日期: Sep 2011
帖子: 44
现金:136金币
资产:136金币
声望力: 0
声望: 10 rtyfgh 向着好的方向发展
声望力: 0
rtyfgh 向着好的方向发展
回复: ISIS路由泄露(简化)及多L1区域运行在同一路由器

在公司用了款美信CreCloud云网管,挺不错的,属于云计算技术理念和IT监控技术的完美结合,云网管的成功开发和应用,使云计算理念在IT监控领域落地,而且还是永久免费 ww w.mxsoft.com
帅哥 rtyfgh 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 00:06


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号