Cisco网络技术论坛

返回   Cisco网络技术论坛 > 网络技术区 > 协议原理综合区

协议原理综合区 网络协议、网络基础原理等

发表新主题 回复
 
主题工具
旧 2007-04-22, 23:51   #46
alanbell
注册用户
级别:1 | 在线时长:7小时 | 升级还需:5小时
 
注册日期: Apr 2007
住址: 广州市
帖子: 4
现金:0金币
资产:0金币
声望力: 0
声望: 10 alanbell 向着好的方向发展
声望力: 0
alanbell 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

很难说的清楚什么时候用什么协议!
alanbell 当前离线  
回复时引用此帖
旧 2007-04-25, 19:01   #47
moodchild
黑夜司令
级别:1 | 在线时长:9小时 | 升级还需:3小时
 
moodchild 的头像
 
注册日期: Mar 2007
住址: 神仙岛
帖子: 25
现金:38金币
资产:38金币
声望力: 0
声望: 10 moodchild 向着好的方向发展
声望力: 0
moodchild 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

不枉此行!!!学到东西了!!!!

管你给不给,你都要给!!
帅哥 moodchild 当前离线  
回复时引用此帖
旧 2007-04-26, 09:50   #48
Tornado_h2k
注册用户
级别:4 | 在线时长:34小时 | 升级还需:11小时级别:4 | 在线时长:34小时 | 升级还需:11小时级别:4 | 在线时长:34小时 | 升级还需:11小时级别:4 | 在线时长:34小时 | 升级还需:11小时
 
注册日期: Oct 2005
住址: Tianjin
帖子: 21
现金:79金币
资产:79金币
声望力: 0
声望: 10 Tornado_h2k 向着好的方向发展
声望力: 0
Tornado_h2k 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

顶个
Tornado_h2k 当前离线  
回复时引用此帖
旧 2007-04-26, 12:46   #49
带脚镣跳舞
注册用户
级别:6 | 在线时长:63小时 | 升级还需:14小时级别:6 | 在线时长:63小时 | 升级还需:14小时
 
带脚镣跳舞 的头像
 
注册日期: Mar 2004
住址: 江苏
帖子: 66
现金:211金币
资产:211金币
声望力: 15
声望: 10 带脚镣跳舞 向着好的方向发展
声望力: 15
带脚镣跳舞 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

引用:
作者: pushupan 查看帖子
还有一种情况,没有说到:
当query报文设置为不可截断时,如果返回的报文的长度大于512字节,那么只返回报文的512字节,因此client必须发起TCP的query报文给DNS
这个是对的

--------------------------------------------------------------------------------
其实首先应该搞清楚什么是TCP,什么是UDP,TCP是用于传输层地传输控制协议,UDP也是用于传输层,TCP是面向连接地,UDP是面向非连接地,面向连接是要建立,通信,撤销连接地,传输质量高,非面向连接地是没有要求连接地,只发送数据包,不保证接收端收得到,如果使用TCP/IP协议地话,在局域网中用地是PPP帧,应为在局域网内传输质量高,这种帧是没有发送序列号和验证地。DNS是域名解释系统,是用来对IP地址和域名地转换,什么时候用TCP和UDP,这个和DNS是没有关系地,如果确定什么时候用TCP,什么时候用UDP,这个要看你使用地软件采用什么方式进行通信,比如说QQ BT是UDP,
-------------------------------------------------------------------------------------------------
误导大家

zone transfer TCP
DNS报文超过512字节会截断 然后使用TCP协议从新发送

和WAN还是LAN无关 和什么可靠不可靠也无关
带脚镣跳舞 当前离线  
回复时引用此帖
旧 2007-04-26, 13:03   #50
lsw_750405
注册用户
级别:0 | 在线时长:1小时 | 升级还需:4小时
 
注册日期: Apr 2007
住址: 山西
帖子: 5
现金:9金币
资产:9金币
声望力: 0
声望: 10 lsw_750405 向着好的方向发展
声望力: 0
lsw_750405 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

终于对TCP、UDP有了一点了解
lsw_750405 当前离线  
回复时引用此帖
旧 2007-04-26, 23:31   #51
act_soul
注册用户
级别:1 | 在线时长:6小时 | 升级还需:6小时
 
注册日期: Apr 2007
住址: 泉州
帖子: 30
现金:78金币
资产:78金币
声望力: 0
声望: 10 act_soul 向着好的方向发展
声望力: 0
act_soul 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

看帖不回,杀!-------斑竹够狠,怕了,只有回了,....
act_soul 当前离线  
回复时引用此帖
旧 2007-04-27, 15:37   #52
waltz
注册用户
级别:0 | 在线时长:0小时 | 升级还需:5小时
 
注册日期: Apr 2007
住址: 番禺
帖子: 3
现金:8金币
资产:8金币
声望力: 0
声望: 10 waltz 向着好的方向发展
声望力: 0
waltz 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

我觉得你们上面的回答都不正确,这是通过DNS与防火墙之间的关系决定的!首先理解一下防火墙的原理!
waltz 当前离线  
回复时引用此帖
旧 2007-05-09, 19:25   #53
sam0513
注册用户
级别:1 | 在线时长:11小时 | 升级还需:1小时
 
注册日期: Aug 2006
住址: 北京
帖子: 2
现金:2金币
资产:2金币
声望力: 0
声望: 10 sam0513 向着好的方向发展
声望力: 0
sam0513 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

长见识了,谢谢楼主,我原来以为全都使用TCP的。
sam0513 当前离线  
回复时引用此帖
旧 2007-05-11, 09:16   #54
star_astro
注册用户
级别:19 | 在线时长:468小时 | 升级还需:12小时级别:19 | 在线时长:468小时 | 升级还需:12小时级别:19 | 在线时长:468小时 | 升级还需:12小时级别:19 | 在线时长:468小时 | 升级还需:12小时级别:19 | 在线时长:468小时 | 升级还需:12小时级别:19 | 在线时长:468小时 | 升级还需:12小时级别:19 | 在线时长:468小时 | 升级还需:12小时
 
star_astro 的头像
 
注册日期: Feb 2007
住址: 天津
帖子: 290
现金:620金币
资产:620金币
声望力: 12
声望: 10 star_astro 向着好的方向发展
声望力: 12
star_astro 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

49楼正解,貌似有很多“高手”在这鱼目混珠。。。。
star_astro 当前离线  
回复时引用此帖
旧 2007-05-12, 13:13   #55
juhuatai2007
注册用户
级别:1 | 在线时长:10小时 | 升级还需:2小时
 
juhuatai2007 的头像
 
注册日期: Apr 2007
住址: 吉林省
帖子: 9
现金:38金币
资产:38金币
声望力: 0
声望: 10 juhuatai2007 向着好的方向发展
声望力: 0
juhuatai2007 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

顶一下!!
juhuatai2007 当前离线  
回复时引用此帖
旧 2007-07-09, 13:51   #56
Y108
注册用户
级别:2 | 在线时长:19小时 | 升级还需:2小时级别:2 | 在线时长:19小时 | 升级还需:2小时
 
注册日期: Jul 2007
住址: 北京
帖子: 4
现金:10金币
资产:10金币
声望力: 0
声望: 10 Y108 向着好的方向发展
声望力: 0
Y108 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

好啊,学习了.
Y108 当前离线  
回复时引用此帖
旧 2007-07-09, 14:02   #57
ghzhang
注册用户
级别:1 | 在线时长:5小时 | 升级还需:7小时
 
ghzhang 的头像
 
注册日期: Jul 2007
住址: 内蒙古自治区
帖子: 16
现金:34金币
资产:34金币
声望力: 0
声望: 10 ghzhang 向着好的方向发展
声望力: 0
ghzhang 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

R4(config)#interface Loopback0
R4(config-if)# ip address 4.4.4.4 255.255.255.0
R4(config-if)#exit
R4(config)#interface FastEthernet0/0
R4(config-if)# ip address 43.43.43.4 255.255.255.0
R4(config-if)#no shut
R4(config-if)#exit
R4(config)#interface Serial0/0
R4(config-if)# ip address 34.34.34.4 255.255.255.0
R4(config-if)# clockrate 128000
R4(config-if)#no shut
R4(config)#router eigrp 1
R4(config-router)# network 4.4.4.0 0.0.0.255
R4(config-router)# network 34.34.34.0 0.0.0.255
R4(config-router)# network 43.43.43.0 0.0.0.255
R4(config-router)#variance 10
R4(config-router)# no auto-summary
R4(config-router)#end


R1#show ip eigrp neighbors
R1#show ip eigrp topology
R1#show ip route
这些是什么意思

相信自己
ghzhang 当前离线  
回复时引用此帖
旧 2007-07-10, 15:54   #58
lsh0329
注册用户
级别:6 | 在线时长:71小时 | 升级还需:6小时级别:6 | 在线时长:71小时 | 升级还需:6小时
 
注册日期: Oct 2004
住址: lsh
帖子: 120
现金:144金币
资产:144金币
声望力: 15
声望: 10 lsh0329 向着好的方向发展
声望力: 15
lsh0329 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

知道了。谢谢。
lsh0329 当前离线  
回复时引用此帖
旧 2007-09-18, 10:10   #59
lanwei0050
新手上路
级别:0 | 在线时长:1小时 | 升级还需:4小时
 
注册日期: Aug 2007
住址: beijing
帖子: 1
现金:3金币
资产:3金币
声望力: 0
声望: 10 lanwei0050 向着好的方向发展
声望力: 0
lanwei0050 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

DNS 查询分为 递归查询;迭代查询
递归查询时用TCP
迭代查询时用UDP
帅哥 lanwei0050 当前离线  
回复时引用此帖
旧 2007-09-24, 17:38   #60
最爱!!!!!
注册用户
级别:2 | 在线时长:18小时 | 升级还需:3小时级别:2 | 在线时长:18小时 | 升级还需:3小时
 
最爱!!!!! 的头像
 
注册日期: Sep 2007
住址: 湖南
帖子: 76
现金:144金币
资产:144金币
声望力: 12
声望: 10 最爱!!!!! 向着好的方向发展
声望力: 12
最爱!!!!! 向着好的方向发展
回复: DNS什么时候使用TCP,时候使用UDP?

学了

明白的是道理.行动后才会有收获www.snwei.com希望能够伴你成长
最爱!!!!! 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 21:04


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号