Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
推荐为精华主题  
主题工具
旧 2003-11-11, 10:39   #1
沙漠灵魂
.....沙漠上空的风
级别:16 | 在线时长:347小时 | 升级还需:10小时级别:16 | 在线时长:347小时 | 升级还需:10小时级别:16 | 在线时长:347小时 | 升级还需:10小时级别:16 | 在线时长:347小时 | 升级还需:10小时
 
沙漠灵魂 的头像
 
注册日期: Apr 2003
住址: 昆山
帖子: 1,338
现金:2661金币
资产:2661金币
声望力: 16
声望: 10 沙漠灵魂 向着好的方向发展
声望力: 16
沙漠灵魂 向着好的方向发展
HSRP with Interface VLANs(可能?大家有用)

Introduction
In this configuration, we have two Catalyst 6509 switches, each with two Multilayer Switch Feature Cards (MSFCs), for a total of four routers. Our strategy is to have the MSFC-a1 in the diagram below route for odd virtual LANs (VLANs), as the primary router, and MSFC-b1 to route odd VLANs as the backup router. For even VLANs, we want MSFC-b2 to be the primary router and MSFC-a2 to be the backup router.

Note: The backup routers (MSFCs) don't have a standby priority explicitly assigned so they default to priority 100. We add the standby preempt statement so that if the primary router goes down and comes back up, it resumes the highest priority, or preempt control.

MSFC-a1配置信息:
msfc-a1#
!
hostname msfc-a1
!
!
interface Vlan1
ip address 1.1.1.2 255.255.0.0
standby 1 priority 110 preempt
standby 1 ip 1.1.1.1
!
interface Vlan3
ip address 3.1.1.2 255.255.0.0
standby 3 priority 110 preempt
standby 3 ip 3.1.1.1
!
!
end

MSFC-a2配置信息:
msfc-a2#
!
hostname msfc-a2
!
!
interface Vlan2
ip address 2.1.1.3 255.255.0.0
standby 2 ip 2.1.1.1
!
interface Vlan4
ip address 4.1.1.3 255.255.0.0
standby 4 ip 4.1.1.1
!
!
end

MSFC-b1配置信息:
msfc-b1#
!
hostname msfc-b1
!
!
interface Vlan1
ip address 1.1.1.3 255.255.0.0
standby 1 ip 1.1.1.1
!
interface Vlan3
ip address 3.1.1.3 255.255.0.0
standby 3 ip 3.1.1.1
!
!
end

MSFC-b2配置信息:
msfc-b2#
!
hostname msfc-b2
!
!
interface Vlan2
ip address 2.1.1.2 255.255.0.0
standby 2 priority 110 preempt
standby 2 ip 2.1.1.1
!
interface Vlan4
ip address 4.1.1.2 255.255.0.0
standby 4 priority 110 preempt
standby 4 ip 4.1.1.1
!
!
!
end

相晷命令陪嘱解如下:
debug and show Commands
Verify that HSRP is working by using the show standby command. In the output below, MSFC-a1 sees its backup router as "Standby router 3.1.1.3."

msfc-a1#show standby
Vlan1 - Group 1
Local state is Active, priority 110, may preempt
Hellotime 3 holdtime 10
Next hello sent in 00:00:01.588
Hot standby IP address is 1.1.1.1 configured
Active router is local
Standby router is 1.1.1.3 expires in 00:00:08
Standby virtual mac address is 0000.0c07.ac01
Vlan3 - Group 3
Local state is Active, priority 110, may preempt
Hellotime 3 holdtime 10
Next hello sent in 00:00:02.092
Hot standby IP address is 3.1.1.1 configured
Active router is local
Standby router is 3.1.1.3 expires in 00:00:08
Standby virtual mac address is 0000.0c07.ac03

When we issue the show standby command from MSFC-b1, we see that for VLAN 1 and 3, MSFC-b1 is the backup or standby router: "Local state is Standby, priority 100." The active router is 1.1.1.2, or MSFC-a1, which has priority 110. Since 110 is greater than 100, MSFC-a1 is the active router.

msfc-b1#show standby
Vlan1 - Group 1
Local state is Standby, priority 100
Hellotime 3 holdtime 10
Next hello sent in 00:00:01.440
Hot standby IP address is 1.1.1.1 configured
Active router is 1.1.1.2 expires in 00:00:09
Standby router is local
Standby virtual mac address is 0000.0c07.ac01
Vlan3 - Group 3
Local state is Standby, priority 100
Hellotime 3 holdtime 10
Next hello sent in 00:00:01.478
Hot standby IP address is 3.1.1.1 configured
Active router is 3.1.1.2 expires in 00:00:09
Standby router is local
Standby virtual mac address is 0000.0c07.ac03

When HSRP isn't configured correctly, you see show standby output similar to that below, which shows MSFC-b2 doesn't see its HSRP partner.

msfc-b2#show standby
Vlan2 - Group 2
Local state is Active, priority 110, may preempt
Hellotime 3 holdtime 10
Next hello sent in 00:00:02.904
Hot standby IP address is 2.1.1.1 configured
Active router is local
Standby router is unknown expired

When you see this output, first check that the configuration is correct. Then verify that all the VLANs are passing through the trunk between the two switches. In the output below, VLANs 1 through 4 are passing through correctly.

Switch (enable)#show trunk 8/1
Port Mode Encapsulation Status Native vlan
-------- ----------- ------------- ------------ -----------
8/1 desirable n-isl trunking 1

Port Vlans allowed on trunk
----------------------------------------------------------------
8/1 1-1005

Port Vlans allowed and active in management domain
----------------------------------------------------------------
8/1 1-4

Port Vlans in spanning tree forwarding state and not pruned
----------------------------------------------------------------
8/1 1-4

If you're still running into issues, ensure that the virtual VLAN interfaces are up by issuing the show interface vlan <vlan #> command.

咀疥?如下:
上传的图像
文件类型: gif 4a.gif (5.8 KB, 4202 次查看)

我的第二情人-----咀疥

msn:wangsline@hotmail.com

http://bbs.nphtl.com.cn/uploadfile/2.jpg
沙漠灵魂 当前离线  
回复时引用此帖
旧 2003-11-11, 10:47   #2
沙漠灵魂
.....沙漠上空的风
级别:16 | 在线时长:347小时 | 升级还需:10小时级别:16 | 在线时长:347小时 | 升级还需:10小时级别:16 | 在线时长:347小时 | 升级还需:10小时级别:16 | 在线时长:347小时 | 升级还需:10小时
 
沙漠灵魂 的头像
 
注册日期: Apr 2003
住址: 昆山
帖子: 1,338
现金:2661金币
资产:2661金币
声望力: 16
声望: 10 沙漠灵魂 向着好的方向发展
声望力: 16
沙漠灵魂 向着好的方向发展
呃?快就加?精啊。哪我要多傥??哦。
沙漠灵魂 当前离线  
回复时引用此帖
旧 2003-11-11, 14:07   #3
黑夜步行者
unbanned
级别:51 | 在线时长:2843小时 | 升级还需:69小时级别:51 | 在线时长:2843小时 | 升级还需:69小时级别:51 | 在线时长:2843小时 | 升级还需:69小时
 
黑夜步行者 的头像
 
注册日期: Apr 2003
住址: 上海滩
帖子: 10,760
积分:-15
精华:-14
现金:3747金币
资产:3747金币
声望力: 27
声望: 222 黑夜步行者 身上有一圈迷人的光环哦黑夜步行者 身上有一圈迷人的光环哦黑夜步行者 身上有一圈迷人的光环哦
声望力: 27
黑夜步行者 身上有一圈迷人的光环哦黑夜步行者 身上有一圈迷人的光环哦黑夜步行者 身上有一圈迷人的光环哦
SP

给我五千名城管,便可踏平东京城。
黑夜步行者 当前离线  
回复时引用此帖
旧 2003-11-13, 14:27   #4
y7975
师父给的名字=土人 =
级别:25 | 在线时长:742小时 | 升级还需:38小时
 
y7975 的头像
 
注册日期: Jul 2003
住址: 纽约
帖子: 1,987
积分:1
精华:1
现金:4324金币
资产:4324金币
声望力: 16
声望: 113 y7975 是将要出名的人啊y7975 是将要出名的人啊
声望力: 16
y7975 是将要出名的人啊y7975 是将要出名的人啊
引用:
We add the standby preempt statement so that if the primary router goes down and comes back up, it resumes the highest priority, or preempt control.
personal suggestion: NOT to use preempt

reason is:

both MSFC is equal powerful, no need to switch back to the Original primary. the time primary router goes down and comes back up, you will experience SERVICE INTERRUPT, if you have real time application, packet will DROP or retransmit, depend on the protocol.

[img] [/img]new qq:1651898142 msn:net130_0 at yahoo.com
y7975 当前离线  
回复时引用此帖
旧 2003-12-22, 11:31   #5
summercook
注册用户
级别:7 | 在线时长:92小时 | 升级还需:4小时级别:7 | 在线时长:92小时 | 升级还需:4小时级别:7 | 在线时长:92小时 | 升级还需:4小时
 
summercook 的头像
 
注册日期: Nov 2003
住址: 天上
帖子: 286
现金:572金币
资产:572金币
声望力: 14
声望: 10 summercook 向着好的方向发展
声望力: 14
summercook 向着好的方向发展
为什么要用preempt?primary router在断掉又恢复之后,不能成为active吗?

hello
summercook 当前离线  
回复时引用此帖
旧 2003-12-22, 12:07   #6
123456789
注册用户
级别:13 | 在线时长:230小时 | 升级还需:22小时级别:13 | 在线时长:230小时 | 升级还需:22小时级别:13 | 在线时长:230小时 | 升级还需:22小时级别:13 | 在线时长:230小时 | 升级还需:22小时级别:13 | 在线时长:230小时 | 升级还需:22小时
 
123456789 的头像
 
注册日期: Sep 2003
住址: zz
帖子: 773
现金:1531金币
资产:1531金币
声望力: 14
声望: 10 123456789 向着好的方向发展
声望力: 14
123456789 向着好的方向发展
我见过同样的硬件配置,但是它是四块MSFC作热备!!
楼主的是两个主MSFC作热备,两个备MSFC作热备!这样的话,是不是同一个65的两个MSFC就不用作同步?
123456789 当前离线  
回复时引用此帖
旧 2003-12-27, 19:26   #7
seiry
注册用户
级别:11 | 在线时长:184小时 | 升级还需:8小时级别:11 | 在线时长:184小时 | 升级还需:8小时级别:11 | 在线时长:184小时 | 升级还需:8小时
 
seiry 的头像
 
注册日期: May 2003
住址: 杭州
帖子: 367
现金:733金币
资产:733金币
声望力: 15
声望: 10 seiry 向着好的方向发展
声望力: 15
seiry 向着好的方向发展
不用这么夸张吧,四个MSFC做备份!?

seiry 当前离线  
回复时引用此帖
旧 2004-01-09, 17:10   #8
alluler
注册用户
级别:5 | 在线时长:52小时 | 升级还需:8小时
 
alluler 的头像
 
注册日期: Jan 2004
住址: GZ
帖子: 15
现金:30金币
资产:30金币
声望力: 0
声望: 10 alluler 向着好的方向发展
声望力: 0
alluler 向着好的方向发展
看着眼花,4各msfc做备份,这也太保险了吧。

这么多年了,火气还是那么大,其实我的火气也很大,常得罪人,常摆着一张臭脸以为天命最高,唯我独大,藐视一切,咒骂所有。大哥嘛,嘿嘿,自然要吊那么一点。
alluler 当前离线  
回复时引用此帖
旧 2004-01-19, 17:45   #9
zhenghuiming
注册用户
级别:8 | 在线时长:99小时 | 升级还需:18小时级别:8 | 在线时长:99小时 | 升级还需:18小时级别:8 | 在线时长:99小时 | 升级还需:18小时级别:8 | 在线时长:99小时 | 升级还需:18小时
 
注册日期: Oct 2003
住址: df
帖子: 83
现金:170金币
资产:170金币
声望力: 14
声望: 10 zhenghuiming 向着好的方向发展
声望力: 14
zhenghuiming 向着好的方向发展
加了preempt的话。他down完up后会从新抢回做active route
zhenghuiming 当前离线  
回复时引用此帖
旧 2004-01-19, 18:46   #10
iszq
注册用户
级别:0 | 在线时长:3小时 | 升级还需:2小时
 
注册日期: Jan 2004
住址: 不要?我?哪奄?
帖子: 10
现金:20金币
资产:20金币
声望力: 0
声望: 10 iszq 向着好的方向发展
声望力: 0
iszq 向着好的方向发展
引用:
最初由 y7975 发布
personal suggestion: NOT to use preempt

reason is:

both MSFC is equal powerful, no need to switch back to the Original primary. the time primary router goes down and comes back up, you will experience SERVICE INTERRUPT, if you have real time application, packet will DROP or retransmit, depend on the protocol.
Yes!
You can solve this by configure a delay value.
iszq 当前离线  
回复时引用此帖
旧 2004-04-01, 16:47   #11
flycai
注册用户
级别:8 | 在线时长:103小时 | 升级还需:14小时级别:8 | 在线时长:103小时 | 升级还需:14小时级别:8 | 在线时长:103小时 | 升级还需:14小时级别:8 | 在线时长:103小时 | 升级还需:14小时
 
注册日期: Jul 2003
住址: 安徽合肥
帖子: 5
现金:10金币
资产:10金币
声望力: 0
声望: 10 flycai 向着好的方向发展
声望力: 0
flycai 向着好的方向发展
不太合理

没有合理利用资源!应该达到的安全级别没有达到!
flycai 当前离线  
回复时引用此帖
旧 2004-07-15, 13:57   #12
song2744
注册用户
级别:4 | 在线时长:39小时 | 升级还需:6小时级别:4 | 在线时长:39小时 | 升级还需:6小时级别:4 | 在线时长:39小时 | 升级还需:6小时级别:4 | 在线时长:39小时 | 升级还需:6小时
 
song2744 的头像
 
注册日期: Apr 2004
住址: 北京
帖子: 108
现金:216金币
资产:216金币
声望力: 14
声望: 10 song2744 向着好的方向发展
声望力: 14
song2744 向着好的方向发展
要求的总比能实现的要少。

song2744 当前离线  
回复时引用此帖
旧 2004-07-18, 19:44   #13
F50
注册用户
级别:4 | 在线时长:34小时 | 升级还需:11小时级别:4 | 在线时长:34小时 | 升级还需:11小时级别:4 | 在线时长:34小时 | 升级还需:11小时级别:4 | 在线时长:34小时 | 升级还需:11小时
 
注册日期: Jul 2004
住址: 二亿年前
帖子: 97
现金:186金币
资产:186金币
声望力: 13
声望: 10 F50 向着好的方向发展
声望力: 13
F50 向着好的方向发展
这叫人怎么实现呢呀。。。。也太贵了点吧。。。两个就够多D了中。。

男)真情真美,真如一池春水
风吹点点涟漪,感受细致入微
(女)痴心无罪,付出没有不对
就算一生一世,从此相依相随
(男)不必在乎是谁,翻转是是非非
把前尘做白纸,写上无怨无悔。
(女)我们都愿意给,只要爱的纯粹
就算有苦有累,我们一起去背
(合)爱是多么可贵,贵在有所作为
只要同去同归,成败也无所谓
(男)来日风雨中有没有伤悲,
无论怎么样一起来面对
百转千回,纵横南北
敞开我们的心扉
成败也无所谓
F50 当前离线  
回复时引用此帖
旧 2016-12-22, 11:45   #14
chenxliang
注册用户
级别:1 | 在线时长:7小时 | 升级还需:5小时
 
注册日期: Aug 2016
帖子: 261
现金:986金币
资产:986金币
声望力: 1
声望: 10 chenxliang 向着好的方向发展
声望力: 1
chenxliang 向着好的方向发展
回复: 【原创】HSRP with Interface VLANs(可能?大家有用)

还在花钱培训?那你亏大了!
ITGeGe知识共享社区推出名师课堂,想学就学,首期思科、华为、华三名师免费直播!

12月18日HCIE RS考题出题官韩士良老师主讲HCNA
http://www.itgege.com/course/275

12月19日资深思科认证名师“红头发”朱极老师主讲CCNA
http://www.itgege.com/course/281

12月20日Cisco认证名师李华成老师主讲CCNP
http://www.itgege.com/course/315

12月20日华为认证名师Samuel耿主讲HCNP
http://www.itgege.com/course/313

12月20日H3C终身荣誉金牌讲师尹光成主讲H3CNE
http://www.itgege.com/course/316

12月20日H3C金牌培训讲师王俊强主讲H3CSE
http://www.itgege.com/course/314

六大名师倾囊相授,网络技术轻松掌握!
详情见www.itgege.com
美女 chenxliang 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 09:08


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2017,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号