Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
 
主题工具
旧 2004-04-26, 16:23   #1
tonyxue
注册用户
级别:9 | 在线时长:125小时 | 升级还需:15小时级别:9 | 在线时长:125小时 | 升级还需:15小时级别:9 | 在线时长:125小时 | 升级还需:15小时级别:9 | 在线时长:125小时 | 升级还需:15小时级别:9 | 在线时长:125小时 | 升级还需:15小时
 
注册日期: Mar 2004
住址: 上海
帖子: 111
现金:318金币
资产:318金币
声望力: 15
声望: 10 tonyxue 向着好的方向发展
声望力: 15
tonyxue 向着好的方向发展
[原创]FTTB+NAT+DHCP+pppoe+CBAC+vpn client+Authentication AAA

成功配置,已经调试成功的说!
hongyi#show run
Building configuration...

Current configuration : 4655 bytes
!
! Last configuration change at 04:47:29 UTC Sun Apr 25 2004 by tonyxue
! NVRAM config last updated at 04:47:50 UTC Sun Apr 25 2004 by tonyxue
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname hongyi
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$nyjl$3Q7avJNhGMGg9h8S3TxL01
!
username tonyxue password 7 110B0B0C101A1F010524
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
aaa new-model
!
!
aaa authentication login hongyi_authen group tacacs+
aaa authentication login no_tacasc enable
aaa authentication login line_vty local
aaa authorization network hongyi_author local
aaa session-id common
ip subnet-zero
no ip source-route
!
!
no ip domain lookup
ip dhcp excluded-address 172.16.0.1 172.16.0.220
!
ip dhcp pool hongyi
network 172.16.0.0 255.255.255.0
dns-server 202.96.209.5 202.96.209.133
default-router 172.16.0.10
lease 30
!
no ip bootp server
ip cef
ip inspect audit-trail
ip inspect name firewall cuseeme
ip inspect name firewall fragment maximum 256 timeout 1
ip inspect name firewall ftp
ip inspect name firewall h323
ip inspect name firewall icmp
ip inspect name firewall netshow
ip inspect name firewall rcmd
ip inspect name firewall realaudio
ip inspect name firewall rtsp
ip inspect name firewall sqlnet
ip inspect name firewall streamworks
ip inspect name firewall tcp
ip inspect name firewall udp
ip inspect name firewall vdolive
ip inspect name firewall http
ip audit po max-events 100
vpdn enable
!
vpdn-group FTTB
request-dialin
protocol pppoe
!
no ftp-server write-enable
!
!
!
!
!
crypto isakmp policy 3
encr 3des
authentication pre-share
group 2
!
crypto isakmp client configuration group hongyi
key *********
pool hongyi_pool
!
!
crypto ipsec transform-set hongyi_set esp-3des esp-sha-hmac
!
crypto dynamic-map hongyi_dynamic_map 10
set transform-set hongyi_set
!
!
crypto map clientmap client authentication list hongyi_authen
crypto map clientmap isakmp authorization list hongyi_author
crypto map clientmap client configuration address respond
crypto map clientmap 10 ipsec-isakmp dynamic hongyi_dynamic_map
!
!
!
interface Ethernet0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
half-duplex
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0
ip address 172.16.0.10 255.255.0.0
ip access-group Local_Ruler in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip tcp adjust-mss 1452
no ip mroute-cache
speed auto
no cdp enable
!
interface Dialer1
mtu 1492
ip address negotiated
ip access-group Outbound_Ruler in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip inspect firewall out
encapsulation ppp
no ip mroute-cache
dialer pool 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username ad********* @shtel password 7 046B08133D255F7908
crypto map clientmap
!
ip local pool hongyi_pool 192.168.0.1 192.168.0.254
ip nat inside source route-map nat_map interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
!
!
ip access-list extended Local_Ruler
deny 53 any any log
deny 55 any any log
deny pim any any log
deny tcp any any eq echo log
deny tcp any any eq chargen log
deny tcp any any eq 135 log
deny tcp any any eq 136 log
deny tcp any any eq 137 log
deny tcp any any eq 138 log
deny tcp any any eq 139 log
deny tcp any any eq 445 log
deny tcp any any eq 4444 log
deny udp any any eq tftp log
deny udp any any eq 135 log
deny udp any any eq 136 log
deny udp any any eq netbios-ns log
deny udp any any eq netbios-dgm log
deny udp any any eq netbios-ss log
deny udp any any eq snmp log
deny udp any any eq 445 log
permit ip any any
ip access-list extended Outbound_Ruler
permit udp any any eq isakmp log
permit esp any any log
permit udp any any eq non500-isakmp log
permit ip 192.168.0.0 0.0.0.255 172.16.0.0 0.0.255.255 log
deny ip any any log
logging source-interface FastEthernet0
logging 172.16.0.100
access-list 1 deny any
access-list 101 deny ip 172.16.0.0 0.0.255.255 192.168.0.0 0.0.0.255
access-list 101 permit ip 172.16.0.0 0.0.255.255 any
no cdp run
!
route-map nat_map permit 10
match ip address 101
!
tacacs-server host 172.16.0.100 key 7 0459190F082958430817
tacacs-server directed-request
!
line con 0
logging synchronous
login authentication line_vty
line aux 0
logging synchronous
line vty 0 4
logging synchronous
login authentication line_vty
!
!
end

此帖于 2004-04-26 16:37 被 tonyxue 编辑。
tonyxue 当前离线  
回复时引用此帖
旧 2004-04-26, 16:27   #2
xsyhome
注册用户
级别:10 | 在线时长:140小时 | 升级还需:25小时级别:10 | 在线时长:140小时 | 升级还需:25小时
 
注册日期: Dec 2003
住址: jiangsu
帖子: 314
现金:630金币
资产:630金币
声望力: 15
声望: 10 xsyhome 向着好的方向发展
声望力: 15
xsyhome 向着好的方向发展
太谢谢了
xsyhome 当前离线  
回复时引用此帖
旧 2004-04-26, 16:37   #3
麦客属马
版主
级别:35 | 在线时长:1420小时 | 升级还需:20小时级别:35 | 在线时长:1420小时 | 升级还需:20小时级别:35 | 在线时长:1420小时 | 升级还需:20小时
 
麦客属马 的头像
 
注册日期: Aug 2003
住址: 深圳
帖子: 5,302
精华:3
现金:10282金币
资产:10282金币
声望力: 23
声望: 215 麦客属马 身上有一圈迷人的光环哦麦客属马 身上有一圈迷人的光环哦麦客属马 身上有一圈迷人的光环哦
声望力: 23
麦客属马 身上有一圈迷人的光环哦麦客属马 身上有一圈迷人的光环哦麦客属马 身上有一圈迷人的光环哦
不错。

 
一槁一橹一渔舟,一丈长竿一寸钩,一拍一呼一顿笑,一人独钓一江秋!

一桌一椅一电脑,一种心思一双手,一思一动一堆字,一人独享一园悠!

http://wpa.qq.com/pa?p=1:30488695:2有事儿您Q我,但我通常不在^_^
帅哥 麦客属马 当前离线  
回复时引用此帖
旧 2004-04-27, 02:23   #4
samhui
注册用户
级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时
 
samhui 的头像
 
注册日期: Sep 2003
住址: China
帖子: 117
现金:231金币
资产:231金币
声望力: 16
声望: 10 samhui 向着好的方向发展
声望力: 16
samhui 向着好的方向发展
good
samhui 当前离线  
回复时引用此帖
旧 2004-04-27, 09:00   #5
xiaofeng
注册用户
级别:10 | 在线时长:163小时 | 升级还需:2小时级别:10 | 在线时长:163小时 | 升级还需:2小时
 
xiaofeng 的头像
 
注册日期: Jul 2003
住址: hns
帖子: 157
现金:318金币
资产:318金币
声望力: 16
声望: 10 xiaofeng 向着好的方向发展
声望力: 16
xiaofeng 向着好的方向发展
好!俺顶一下。

有你有他有我,网络才能更精彩!
xiaofeng 当前离线  
回复时引用此帖
旧 2004-04-27, 14:02   #6
pophao
注册用户
级别:7 | 在线时长:82小时 | 升级还需:14小时级别:7 | 在线时长:82小时 | 升级还需:14小时级别:7 | 在线时长:82小时 | 升级还需:14小时
 
pophao 的头像
 
注册日期: Jan 2004
住址: shenzhen
帖子: 26
现金:52金币
资产:52金币
声望力: 0
声望: 10 pophao 向着好的方向发展
声望力: 0
pophao 向着好的方向发展
能否详细讲解一下.
pophao 当前离线  
回复时引用此帖
旧 2005-03-10, 13:46   #7
zcy2003
注册用户
级别:0 | 在线时长:3小时 | 升级还需:2小时
 
zcy2003 的头像
 
注册日期: Feb 2005
住址: 上海
帖子: 3
现金:6金币
资产:6金币
声望力: 0
声望: 10 zcy2003 向着好的方向发展
声望力: 0
zcy2003 向着好的方向发展
这个配置,没有两年的经验是很难写出来的,作者考虑问题非常周到,配置非常到位,仔细留意细微处
zcy2003 当前离线  
回复时引用此帖
旧 2005-04-12, 17:38   #8
lcjyaofa
注册用户
级别:2 | 在线时长:16小时 | 升级还需:5小时级别:2 | 在线时长:16小时 | 升级还需:5小时
 
lcjyaofa 的头像
 
注册日期: Apr 2005
住址: 长沙市
帖子: 8
现金:4金币
资产:4金币
声望力: 0
声望: 10 lcjyaofa 向着好的方向发展
声望力: 0
lcjyaofa 向着好的方向发展
回复: [原创]FTTB+NAT+pppoe+CBAC+vpn client+Authentication AAA

我顶啊呵呵
lcjyaofa 当前离线  
回复时引用此帖
旧 2005-04-23, 21:18   #9
ancy
注册用户
级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时
 
注册日期: Oct 2003
住址: 广东
帖子: 1,204
积分:1
精华:1
现金:3128金币
资产:3128金币
声望力: 16
声望: 34 ancy 向着好的方向发展
声望力: 16
ancy 向着好的方向发展
回复: [原创]FTTB+NAT+pppoe+CBAC+vpn client+Authentication AAA

good
ancy 当前离线  
回复时引用此帖
旧 2005-06-02, 14:42   #10
ssjabcd
注册用户
级别:6 | 在线时长:60小时 | 升级还需:17小时级别:6 | 在线时长:60小时 | 升级还需:17小时
 
注册日期: Apr 2005
住址: 北京
帖子: 95
现金:200金币
资产:200金币
声望力: 14
声望: 10 ssjabcd 向着好的方向发展
声望力: 14
ssjabcd 向着好的方向发展
回复: [原创]FTTB+NAT+pppoe+CBAC+vpn client+Authentication AAA

我天!看晕了 ,顶 !
ssjabcd 当前离线  
回复时引用此帖
旧 2005-06-02, 17:20   #11
天下为公
注册用户
级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时
 
天下为公 的头像
 
注册日期: Aug 2003
住址: 陕西
帖子: 94
现金:187金币
资产:187金币
声望力: 16
声望: 10 天下为公 向着好的方向发展
声望力: 16
天下为公 向着好的方向发展
回复: [原创]FTTB+NAT+pppoe+CBAC+vpn client+Authentication AAA

高手,

前两天群里面有个人问关于这几个配置。

收了,谢谢!!!
天下为公 当前离线  
回复时引用此帖
旧 2005-06-02, 18:56   #12
ty223944
注册用户
级别:2 | 在线时长:20小时 | 升级还需:1小时级别:2 | 在线时长:20小时 | 升级还需:1小时
 
注册日期: Feb 2005
住址: 北京
帖子: 25
现金:64金币
资产:64金币
声望力: 0
声望: 10 ty223944 向着好的方向发展
声望力: 0
ty223944 向着好的方向发展
回复: [原创]FTTB+NAT+pppoe+CBAC+vpn client+Authentication AAA

我顶,你真是及时雨松江。
ty223944 当前离线  
回复时引用此帖
旧 2005-06-06, 17:39   #13
kuaile6150
注册用户
级别:10 | 在线时长:145小时 | 升级还需:20小时级别:10 | 在线时长:145小时 | 升级还需:20小时
 
注册日期: May 2004
住址: FUZHOU
帖子: 116
现金:229金币
资产:229金币
声望力: 15
声望: 10 kuaile6150 向着好的方向发展
声望力: 15
kuaile6150 向着好的方向发展
回复: [原创]FTTB+NAT+pppoe+CBAC+vpn client+Authentication AAA

ip access-list extended Outbound_Ruler
permit udp any any eq isakmp log
permit esp any any log
permit udp any any eq non500-isakmp log
permit ip 192.168.0.0 0.0.0.255 172.16.0.0 0.0.255.255 log
deny ip any any log
---------------------------------------------------
这个访问列表应用在外口,那经过NAT回程的数据的怎么进来?不解,有没有人给个回答
kuaile6150 当前离线  
回复时引用此帖
旧 2005-06-16, 09:28   #14
Inshine
注册用户
级别:5 | 在线时长:45小时 | 升级还需:15小时
 
Inshine 的头像
 
注册日期: Jun 2004
住址: 城市森林
帖子: 34
现金:68金币
资产:68金币
声望力: 0
声望: 10 Inshine 向着好的方向发展
声望力: 0
Inshine 向着好的方向发展
回复: [原创]FTTB+NAT+pppoe+CBAC+vpn client+Authentication AAA

研究一下

我是一只想飞的鱼

却流浪在这城市森林中
Inshine 当前离线  
回复时引用此帖
旧 2005-07-21, 10:59   #15
netgaer
注册用户
级别:3 | 在线时长:22小时 | 升级还需:10小时级别:3 | 在线时长:22小时 | 升级还需:10小时级别:3 | 在线时长:22小时 | 升级还需:10小时
 
注册日期: Jul 2005
住址: 长沙
帖子: 87
现金:174金币
资产:174金币
声望力: 14
声望: 10 netgaer 向着好的方向发展
声望力: 14
netgaer 向着好的方向发展
回复: [原创]FTTB+NAT+pppoe+CBAC+vpn client+Authentication AAA

能不能注释一下啊。。。。看的有点晕!
netgaer 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 12:17


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号