Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
 
主题工具
旧 2004-04-21, 21:33   #1
dean
注册用户
级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时
 
注册日期: Feb 2004
住址: 郑州
帖子: 199
现金:386金币
资产:386金币
声望力: 15
声望: 10 dean 向着好的方向发展
声望力: 15
dean 向着好的方向发展
我被折腾了4天了,4506+2950通过网桥上网,并用dhcp服务器分配ip.

网络是通过网桥连接到总部的,网桥那边的地址是10.20.64.222,一台OA服务器,一台DHCP服务器地址是10.20.64.10,地址池范围10.20.64.1----10.20.71.254,一台4506核心交换机,四台2950接入交换机。现在需要为每个vlan的计算机以dhcp方式分配ip。而且需要能够ping通10.20.64.222。现在能够给每个vlan的计算机分配ip,但是都是随机的,而网关已经指定了都是静态给vlan分配的地址,所以经常不能分配到一个网段的ip,不能连通10.20.64.222。我想知道怎么指定dhcp分配给每个vlan的ip ?

总体需求就是能够动态得到ip地址,并且能够访问10.20.64.222。

以下是我的配置,拜托帮忙看看。配置很长,2950的配置一样,看一个就够了


我快被折腾死了,实在没办法了。请大家帮帮我。

4506配置
Switch>en
Switch#Vlan Database
Switch(Vlan)>vtp domain cisco
Switch(Vlan)>vtp server
Switch(Vlan)>Vlan 2Name work02
Switch(vlan)>Vlan 3 Name work03
Switch(vlan)>Vlan 4 Name work04
Switch(vlan)>Vlan 5 Name work05
Switch(vlan)>Vlan 6 Name work06
Switch(vlan)>Vlan 7 Name work07
Switch(vlan)>Vlan 8 Name work08
Switch(vlan)>Vlan 9 Name work09
Switch(vlan)>Vlan 10 Name work10
Switch(vlan)>Vlan 11 Name work11
Switch(vlan)>Vlan 12 Name work12
Switch(vlan)>Vlan 13 Name work13
Switch(vlan)>Vlan 14 Name work14

switch(config-if)#interface Range GigabitEthernet2/1 - 4
switch(config-if)#switchport trunk encapsulation dot1q
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk allow vlan all
switch(config-if)#no shutdown


Switch>Enable
Switch#Config t
Switch(Config)Service Dhcp
Switch(Config)Ip Dhcp Relay Information trust-all
.

Switch(Config-vlan)>Int Vlan 2
Switch(Config-vlan)Ip Address 10.20.60.1 255.255.255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)exit

Switch(Config-vlan)>Int Vlan 3
Switch(Config-vlan)Ip Address 10.20.60.65 255.255.255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)exit

Switch(Config-vlan)>Int Vlan 4
Switch(Config-vlan)Ip Address 10.20.60.129 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 5
Switch(Config-vlan)Ip Address 10.20.60.193 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 6
Switch(Config-vlan)Ip Address 10.20.61.1 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 7
Switch(Config-vlan)Ip Address 10.20.61.65 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 8
Switch(Config-vlan)Ip Address 10.20.61.129 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 9
Switch(Config-vlan)Ip Address 10.20.61.129 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 10
Switch(Config-vlan)Ip Address 10.20.61.193 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 11
Switch(Config-vlan)Ip Address 10.20.62.1 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 12
Switch(Config-vlan)Ip Address 10.20.62.65 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 13
Switch(Config-vlan)Ip Address 10.20.62.129 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 14
Switch(Config-vlan)Ip Address 10.20.62.193 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 15
Switch(Config-vlan)Ip Address 10.20.63.1 255.255.248.0
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit



Switch(Config)Interface Range Fa 3/1 - 48
Switch(Config-if-range)Switchport Mode Access

Switch(Config)Interface Range Fa 3/1 - 48
Switch(Config-if-range)Switchport Access Vlan 2



Switch(Config)Ip Routing
Switch(config)router rip
Switch(config-router)#network 10.20.64.0



2950(1)配置
switch1#vlan database
switch1(vlan)#vtp domain cisco
switch1(vlan)#vtp client

switch(config-if)#interface GigabitEthernet1/1
switch(config-if)#switchport mode trunk
switch(config-if)#no shutdown

Switch(Config)Interface Range Fa 0/1 - 4
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 3

Switch(Config)Interface Range Fa 0/5 -8
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 4


Switch(Config)Interface Range Fa 0/9 -13
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 5

Switch(Config)Interface Range Fa 0/14 - 18
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 6

Switch(Config)Interface Range Fa 0/19 - 20
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 6

Switch(Config)Interface Range Fa 0/20 - 23
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 7

Switch(Config)Interface Range Fa 0/24 - 27
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 8

Switch(Config)Interface Range Fa 0/28 - 30
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 9

Switch(Config)Interface Range Fa 0/31 - 33
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 10

Switch(Config)Interface Range Fa 0/34 - 36
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 11

Switch(Config)Interface Range Fa 0/37 - 40
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 12

Switch(Config)Interface Range Fa 0/41 - 43
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 13

Switch(Config)Interface Range Fa 0/44 - 45
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 14

Switch(Config)Interface Range Fa 0/46 - 48
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 15
dean 当前离线  
回复时引用此帖
旧 2004-04-21, 22:40   #2
zghs8
注册用户
级别:11 | 在线时长:184小时 | 升级还需:8小时级别:11 | 在线时长:184小时 | 升级还需:8小时级别:11 | 在线时长:184小时 | 升级还需:8小时
 
zghs8 的头像
 
注册日期: Sep 2003
住址: 上海
帖子: 468
现金:918金币
资产:918金币
声望力: 15
声望: 10 zghs8 向着好的方向发展
声望力: 15
zghs8 向着好的方向发展
Switch(Config)Ip Dhcp Pool Test01
/*设置可分配的子网*/
Switch(Config-pool)Network 192.168.2.0 255.255.255.0
/*设置DNS服务器*/
Switch(Config-pool)Dns-server 192.168.2.10
/*设置该子网的网关*/
Switch(Config-pool)Default-router 192.168.2.1

/*配置VLAN 3所用的地址池和相应参数*/
Switch(Config)Ip Dhcp Pool Test02
Switch(Config-pool)Network 192.168.3.0 255.255.255.0
Switch(Config-pool)Dns-server 192.168.2.10
Switch(Config-pool)Default-router 192.168.3.1

/*配置VLAN 4所用的地址池和相应参数*/
Switch(Config)Ip Dhcp Pool Test03
Switch(Config-pool)Network 192.168.4.0 255.255.255.0
Switch(Config-pool)Dns-server 192.168.2.10
Switch(Config-pool)Default-router 192.168.4.1

第六步:设置DHCP保留不分配的地址
Switch(Config)Ip Dhcp Excluded-address 192.168.2.2 192.168.2.10
Switch(Config)Ip Dhcp Excluded-address 192.168.3.2 192.168.3.10
Switch(Config)Ip Dhcp Excluded-address 192.168.4.2 192.168.4.10
zghs8 当前离线  
回复时引用此帖
旧 2004-04-21, 23:03   #3
dean
注册用户
级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时
 
注册日期: Feb 2004
住址: 郑州
帖子: 199
现金:386金币
资产:386金币
声望力: 15
声望: 10 dean 向着好的方向发展
声望力: 15
dean 向着好的方向发展
我看到这一部分了,但是,他好想用3550本身配置的dhcp服务器,怎么把配置的地址池,关联到每个vlan?如果可以,能不能就我的配置给我写一下限制vlan获得ip的这一部分。我有点看不懂前辈写的东西。拜托了,
dean 当前离线  
回复时引用此帖
旧 2004-04-22, 08:19   #4
dean
注册用户
级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时
 
注册日期: Feb 2004
住址: 郑州
帖子: 199
现金:386金币
资产:386金币
声望力: 15
声望: 10 dean 向着好的方向发展
声望力: 15
dean 向着好的方向发展
我顶
dean 当前离线  
回复时引用此帖
旧 2004-04-22, 10:05   #5
zghs8
注册用户
级别:11 | 在线时长:184小时 | 升级还需:8小时级别:11 | 在线时长:184小时 | 升级还需:8小时级别:11 | 在线时长:184小时 | 升级还需:8小时
 
zghs8 的头像
 
注册日期: Sep 2003
住址: 上海
帖子: 468
现金:918金币
资产:918金币
声望力: 15
声望: 10 zghs8 向着好的方向发展
声望力: 15
zghs8 向着好的方向发展
只能到你DHCP SERVER上去设了,
zghs8 当前离线  
回复时引用此帖
旧 2004-04-22, 10:37   #6
dean
注册用户
级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时
 
注册日期: Feb 2004
住址: 郑州
帖子: 199
现金:386金币
资产:386金币
声望力: 15
声望: 10 dean 向着好的方向发展
声望力: 15
dean 向着好的方向发展
dhcp服务器怎么设置?是不是添加多个地址池?添加多个地址池是不是还要在每个地址池上添加路由?添加那条路由?
dean 当前离线  
回复时引用此帖
旧 2004-04-22, 10:39   #7
dean
注册用户
级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时
 
注册日期: Feb 2004
住址: 郑州
帖子: 199
现金:386金币
资产:386金币
声望力: 15
声望: 10 dean 向着好的方向发展
声望力: 15
dean 向着好的方向发展
我整理了我的配置,这是全部
4506配置
Switch>en
Switch#Vlan Database
Switch(Vlan)>vtp domain cisco
Switch(Vlan)>vtp server
Switch(Vlan)>Vlan 2Name work02
Switch(vlan)>Vlan 3 Name work03
Switch(vlan)>Vlan 4 Name work04
Switch(vlan)>Vlan 5 Name work05
Switch(vlan)>Vlan 6 Name work06
Switch(vlan)>Vlan 7 Name work07
Switch(vlan)>Vlan 8 Name work08
Switch(vlan)>Vlan 9 Name work09
Switch(vlan)>Vlan 10 Name work10
Switch(vlan)>Vlan 11 Name work11
Switch(vlan)>Vlan 12 Name work12
Switch(vlan)>Vlan 13 Name work13
Switch(vlan)>Vlan 14 Name work14

switch(config-if)#interface Range GigabitEthernet2/1 - 4
switch(config-if)#switchport trunk encapsulation dot1q
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk allow vlan all
switch(config-if)#no shutdown


Switch>Enable
Switch#Config t
Switch(Config)Service Dhcp
Switch(Config)Ip Dhcp Relay Information trust-all
Switch(Config)ip dhcp server 10.20.64.10 255.255.255.248

Switch(Config-vlan)>Int Vlan 2
Switch(Config-vlan)Ip Address 10.20.60.1 255.255.255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)exit

Switch(Config-vlan)>Int Vlan 3
Switch(Config-vlan)Ip Address 10.20.60.65 255.255.255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)exit

Switch(Config-vlan)>Int Vlan 4
Switch(Config-vlan)Ip Address 10.20.60.129 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 5
Switch(Config-vlan)Ip Address 10.20.60.193 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 6
Switch(Config-vlan)Ip Address 10.20.61.1 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 7
Switch(Config-vlan)Ip Address 10.20.61.65 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 8
Switch(Config-vlan)Ip Address 10.20.61.129 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 9
Switch(Config-vlan)Ip Address 10.20.61.193 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 10
Switch(Config-vlan)Ip Address 10.20.62.1 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 11
Switch(Config-vlan)Ip Address 10.20.62.65 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 12
Switch(Config-vlan)Ip Address 10.20.62.129 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 13
Switch(Config-vlan)Ip Address 10.20.62.193 255.255.255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 14
Switch(Config-vlan)Ip Address 10.20.63.1 255.255. 255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit

Switch(Config-vlan)>Int Vlan 15
Switch(Config-vlan)Ip Address 10.20.63.65 255.255.255.192
Switch(Config-vlan)ip helper-address 10.20.64.10
Switch(Config-vlan)No Shut
Switch(Config-vlan)Exit



Switch(Config)Interface Range Fa 3/1 - 48
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 2

Switch(Config)Ip Dhcp Pool Test02
Switch(Config-pool)Network 10.20.60.0 255.255.255.192
Switch(Config-pool)Default-router 10.20.60.1

Switch(Config)Ip Dhcp Pool Test03
Switch(Config-pool)Network 10.20.60.64 255.255.255.192
Switch(Config-pool)Default-router 10.20.60.65

Switch(Config)Ip Dhcp Pool Test04
Switch(Config-pool)Network 10.20.60.128 255.255.255.192
Switch(Config-pool)Default-router 10.20.60.129

Switch(Config)Ip Dhcp Pool Test05
Switch(Config-pool)Network 10.20.60.192 255.255.255.192
Switch(Config-pool)Default-router 10.20.60.193


Switch(Config)Ip Dhcp Pool Test06
Switch(Config-pool)Network 10.20.61.0 255.255.255.192
Switch(Config-pool)Default-router 10.20.61.1


Switch(Config)Ip Dhcp Pool Test07
Switch(Config-pool)Network 10.20.61.64 255.255.255.192
Switch(Config-pool)Default-router 10.20.61.65


Switch(Config)Ip Dhcp Pool Test08
Switch(Config-pool)Network 10.20.61.128 255.255.255.192
Switch(Config-pool)Default-router 10.20.61.129

Switch(Config)Ip Dhcp Pool Test09
Switch(Config-pool)Network 10.20.61.192 255.255.255.192
Switch(Config-pool)Default-router 10.20.61.193

Switch(Config)Ip Dhcp Pool Test10
Switch(Config-pool)Network 10.20.62.0 255.255.255.192
Switch(Config-pool)Default-router 10.20.62.1

Switch(Config)Ip Dhcp Pool Test11
Switch(Config-pool)Network 10.20.62.64 255.255.255.192
Switch(Config-pool)Default-router 10.20.62.65

Switch(Config)Ip Dhcp Pool Test12
Switch(Config-pool)Network 10.20.62.128 255.255.255.192
Switch(Config-pool)Default-router 10.20.62.129

Switch(Config)Ip Dhcp Pool Test13
Switch(Config-pool)Network 10.20.62.192 255.255.255.192
Switch(Config-pool)Default-router 10.20.62.193

Switch(Config)Ip Dhcp Pool Test14
Switch(Config-pool)Network 10.20.63.0 255.255.255.192
Switch(Config-pool)Default-router 10.20.63.1

Switch(Config)Ip Dhcp Pool Test15
Switch(Config-pool)Network 10.20.63.64 192 255.255.255.192
Switch(Config-pool)Default-router 10.20.63.65

Switch(Config)Ip Routing
Switch(config)router rip
Switch(config-router)#network 10.20.64.0



2950(1)配置
switch1#vlan database
switch1(vlan)#vtp domain cisco
switch1(vlan)#vtp client

switch(config-if)#interface GigabitEthernet1/1
switch(config-if)#switchport mode trunk
switch(config-if)#no shutdown

Switch(Config)Interface Range Fa 0/1 - 48
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 3

2950(2)配置
Switch(Config)Interface Range Fa 0/1 - 6
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 4


Switch(Config)Interface Range Fa 0/11 -13
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 4

Switch(Config)Interface Range Fa 0/18 - 20
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 5

Switch(Config)Interface Range Fa 0/7 - 10
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 5

Switch(Config)interface fa 0/25
Switch(config-if)# Switchport Mode Access
Switch(Config-if)# Switchport Access Vlan 6
Switch(Config)Interface Range Fa 0/14 - 17
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 6

Switch(Config)Interface Range Fa 0/21 - 24
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 6

Switch(Config)Interface Range Fa 0/26 - 27
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 7

Switch(Config)Interface Range Fa 0/30 - 34
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 7

Switch(Config)Interface Range Fa 0/38 - 40
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 7

Switch(Config)Interface Range Fa 0/28 - 29
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 8

Switch(Config)Interface Range Fa 0/35 - 37
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 8

Switch(Config)Interface Range Fa 0/42 - 48
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 9

Switch(Config)Interface Fa 0/41
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 15

2950(3)配置
switch1#vlan database
switch1(vlan)#vtp domain cisco
switch1(vlan)#vtp client

switch(config-if)#interface GigabitEthernet1/1
switch(config-if)#switchport mode trunk
switch(config-if)#no shutdown

Switch(Config)Interface Range Fa 0/1 - 4
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 9

Switch(Config)Interface Fa 0/7
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 10


Switch(Config)Interface Range Fa 0/12 -14
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 10

Switch(Config)Interface fa 0/16
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 10

Switch(Config)Interface Range Fa 0/18 - 21
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 11

Switch(Config)Interface Fa 0/25
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 11

Switch(Config)Interface Range Fa 0/28 - 36
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 12

Switch(Config)Interface Range Fa 0/5 - 6
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 13

Switch(Config)Interface Range Fa 0/8 - 11
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 13

Switch(Config)Interface Fa 0/15
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 13



Switch(Config)Interface Fa 0/17
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 13

Switch(Config)Interface Range Fa 0/22 - 24
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 14

Switch(Config)Interface Range Fa 0/26 -27
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 14

Switch(Config)Interface Range Fa 0/37 -48
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 15


2950(4)配置
switch1#vlan database
switch1(vlan)#vtp domain cisco
switch1(vlan)#vtp client

switch(config-if)#interface GigabitEthernet1/1
switch(config-if)#switchport mode trunk
switch(config-if)#no shutdown

Switch(Config)Interface Fa 0/1
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 4

Switch(Config)Interface Fa 0/3
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 5

Switch(Config)Interface Fa 0/5
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 5

Switch(Config)Interface Fa 0/7
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 6

Switch(Config)Interface Fa 0/13
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 7

Switch(Config)Interface Fa 0/4
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 8

Switch(Config)Interface Fa 0/10
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 8

Switch(Config)Interface Fa 0/14
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 10

Switch(Config)Interface Fa 0/15
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 11

Switch(Config)Interface Fa 0/6
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 12


Switch(Config)Interface Range Fa 0/16- 17
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 12

Switch(Config)Interface Fa 0/2
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 12

Switch(Config)Interface Fa 0/43
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 13


Switch(Config)Interface Fa 0/12
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 13

Switch(Config)Interface Fa 0/11
Switch(Config-if)Switchport Mode Access
Switch(Config-if)Switchport Access Vlan 14

Switch(Config)Interface Range Fa 0/8 - 9
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 15


Switch(Config)Interface Range Fa 0/9 -13
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 5

Switch(Config)Interface Range Fa 0/45 - 48
Switch(Config-if-range)Switchport Mode Access
Switch(Config-if-range)Switchport Access Vlan 15
dean 当前离线  
回复时引用此帖
旧 2004-04-22, 10:43   #8
小菜
注册用户
级别:12 | 在线时长:212小时 | 升级还需:9小时级别:12 | 在线时长:212小时 | 升级还需:9小时级别:12 | 在线时长:212小时 | 升级还需:9小时级别:12 | 在线时长:212小时 | 升级还需:9小时
 
注册日期: Apr 2003
住址: 广东佛山
帖子: 247
现金:494金币
资产:494金币
声望力: 16
声望: 10 小菜 向着好的方向发展
声望力: 16
小菜 向着好的方向发展
你在4506上就可以设dhcp了,只要把地址池定义好,把各个vlan 的网关加进相应地址池的
default-route,就可以与相应的vlan关联起来了。

努力冲刺CCIE中
帅哥 小菜 当前离线  
回复时引用此帖
旧 2004-04-22, 10:44   #9
文明狼
CISCO CSE
级别:32 | 在线时长:1220小时 | 升级还需:1小时级别:32 | 在线时长:1220小时 | 升级还需:1小时级别:32 | 在线时长:1220小时 | 升级还需:1小时级别:32 | 在线时长:1220小时 | 升级还需:1小时
 
文明狼 的头像
 
注册日期: Nov 2003
住址: 武汉
帖子: 6,228
积分:3
精华:3
现金:14776金币
资产:14776金币
声望力: 22
声望: 101 文明狼 是将要出名的人啊文明狼 是将要出名的人啊
声望力: 22
文明狼 是将要出名的人啊文明狼 是将要出名的人啊
引用:
最初由 zghs8 发布
Switch(Config)Ip Dhcp Pool Test01
/*设置可分配的子网*/
Switch(Config-pool)Network 192.168.2.0 255.255.255.0
/*设置DNS服务器*/
Switch(Config-pool)Dns-server 192.168.2.10
/*设置该子网的网关*/
Switch(Config-pool)Default-router 192.168.2.1

/*配置VLAN 3所用的地址池和相应参数*/
Switch(Config)Ip Dhcp Pool Test02
Switch(Config-pool)Network 192.168.3.0 255.255.255.0
Switch(Config-pool)Dns-server 192.168.2.10
Switch(Config-pool)Default-router 192.168.3.1

/*配置VLAN 4所用的地址池和相应参数*/
Switch(Config)Ip Dhcp Pool Test03
Switch(Config-pool)Network 192.168.4.0 255.255.255.0
Switch(Config-pool)Dns-server 192.168.2.10
Switch(Config-pool)Default-router 192.168.4.1

第六步:设置DHCP保留不分配的地址
Switch(Config)Ip Dhcp Excluded-address 192.168.2.2 192.168.2.10
Switch(Config)Ip Dhcp Excluded-address 192.168.3.2 192.168.3.10
Switch(Config)Ip Dhcp Excluded-address 192.168.4.2 192.168.4.10
这个兄弟是对的,你要为每个VLAN分配一个!!!

http://bbs.net130.com/attachment.php?attachmentid=38184&stc=1&d=1166580252F5、CISCO,有需要的联系我!
文明狼 当前离线  
回复时引用此帖
旧 2004-04-22, 10:45   #10
小菜
注册用户
级别:12 | 在线时长:212小时 | 升级还需:9小时级别:12 | 在线时长:212小时 | 升级还需:9小时级别:12 | 在线时长:212小时 | 升级还需:9小时级别:12 | 在线时长:212小时 | 升级还需:9小时
 
注册日期: Apr 2003
住址: 广东佛山
帖子: 247
现金:494金币
资产:494金币
声望力: 16
声望: 10 小菜 向着好的方向发展
声望力: 16
小菜 向着好的方向发展
你少了把各网关作保留地址,不做分配。
帅哥 小菜 当前离线  
回复时引用此帖
旧 2004-04-22, 11:08   #11
dean
注册用户
级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时
 
注册日期: Feb 2004
住址: 郑州
帖子: 199
现金:386金币
资产:386金币
声望力: 15
声望: 10 dean 向着好的方向发展
声望力: 15
dean 向着好的方向发展
大家好热心啊,虽然问题还没有得到解决,但我谢谢大家了。

请问,是不是还要在2k服务器上设置多个地址池?我现在在2k下设置了一个地址池.


如果要是在4506上设置dhcp服务器怎么设置?
dean 当前离线  
回复时引用此帖
旧 2004-04-22, 11:15   #12
sunmoonsea
过路人
级别:12 | 在线时长:213小时 | 升级还需:8小时级别:12 | 在线时长:213小时 | 升级还需:8小时级别:12 | 在线时长:213小时 | 升级还需:8小时级别:12 | 在线时长:213小时 | 升级还需:8小时
 
sunmoonsea 的头像
 
注册日期: Jul 2003
住址: sz
帖子: 659
现金:1290金币
资产:1290金币
声望力: 15
声望: 10 sunmoonsea 向着好的方向发展
声望力: 15
sunmoonsea 向着好的方向发展
你的dhcp服务器要设置多个地址池,分配给不同给不同的vlan,
sunmoonsea 当前离线  
回复时引用此帖
旧 2004-04-22, 11:17   #13
sunmoonsea
过路人
级别:12 | 在线时长:213小时 | 升级还需:8小时级别:12 | 在线时长:213小时 | 升级还需:8小时级别:12 | 在线时长:213小时 | 升级还需:8小时级别:12 | 在线时长:213小时 | 升级还需:8小时
 
sunmoonsea 的头像
 
注册日期: Jul 2003
住址: sz
帖子: 659
现金:1290金币
资产:1290金币
声望力: 15
声望: 10 sunmoonsea 向着好的方向发展
声望力: 15
sunmoonsea 向着好的方向发展
建议在2000上作dhcp,在核心上作降低其效率
sunmoonsea 当前离线  
回复时引用此帖
旧 2004-04-22, 11:36   #14
小菜
注册用户
级别:12 | 在线时长:212小时 | 升级还需:9小时级别:12 | 在线时长:212小时 | 升级还需:9小时级别:12 | 在线时长:212小时 | 升级还需:9小时级别:12 | 在线时长:212小时 | 升级还需:9小时
 
注册日期: Apr 2003
住址: 广东佛山
帖子: 247
现金:494金币
资产:494金币
声望力: 16
声望: 10 小菜 向着好的方向发展
声望力: 16
小菜 向着好的方向发展
我曾在6506上给2000多个点做dhcp,cpu的利用率也只是10%左右,4506应该不会差太多吧!
帅哥 小菜 当前离线  
回复时引用此帖
旧 2004-04-22, 11:43   #15
dean
注册用户
级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时级别:8 | 在线时长:113小时 | 升级还需:4小时
 
注册日期: Feb 2004
住址: 郑州
帖子: 199
现金:386金币
资产:386金币
声望力: 15
声望: 10 dean 向着好的方向发展
声望力: 15
dean 向着好的方向发展
怎么做?楼上的能不能给一下配置?
dean 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 03:51


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号