Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
推荐为精华主题  
主题工具
旧 2004-04-15, 00:33   #46
mllife
注册用户
级别:7 | 在线时长:83小时 | 升级还需:13小时级别:7 | 在线时长:83小时 | 升级还需:13小时级别:7 | 在线时长:83小时 | 升级还需:13小时
 
mllife 的头像
 
注册日期: Jan 2004
住址: 北京
帖子: 43
现金:94金币
资产:94金币
声望力: 0
声望: 10 mllife 向着好的方向发展
声望力: 0
mllife 向着好的方向发展
同意楼上的说法,源地址策略比较好了
mllife 当前离线  
回复时引用此帖
旧 2004-04-15, 11:34   #47
mllife
注册用户
级别:7 | 在线时长:83小时 | 升级还需:13小时级别:7 | 在线时长:83小时 | 升级还需:13小时级别:7 | 在线时长:83小时 | 升级还需:13小时
 
mllife 的头像
 
注册日期: Jan 2004
住址: 北京
帖子: 43
现金:94金币
资产:94金币
声望力: 0
声望: 10 mllife 向着好的方向发展
声望力: 0
mllife 向着好的方向发展
首先防火墙外口是可以配置两个IP地址,然后分别作NAT,可以分别映射两个网段,然后再在路尤器上进行策略路由即可。
mllife 当前离线  
回复时引用此帖
旧 2004-04-15, 11:50   #48
quhl_baichao
注册用户
级别:5 | 在线时长:55小时 | 升级还需:5小时
 
注册日期: Apr 2004
住址: 北京海淀区
帖子: 4
现金:8金币
资产:8金币
声望力: 0
声望: 10 quhl_baichao 向着好的方向发展
声望力: 0
quhl_baichao 向着好的方向发展
很简单嘛!!

(config)#ip route 0.0.0.0 0.0.0.0 218.x.x.102
(config)#ip route 0.0.0.0 0.0.0.0 218.x.x.126
两条默认路由是自动起负载均衡;
quhl_baichao 当前离线  
回复时引用此帖
旧 2004-04-15, 16:59   #49
teru
超级版主
级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时
 
teru 的头像
 
注册日期: May 2003
住址: macau
帖子: 3,487
现金:6918金币
资产:6918金币
声望力: 19
声望: 23 teru 向着好的方向发展
声望力: 19
teru 向着好的方向发展
Re: 很简单嘛!!

引用:
最初由 quhl_baichao 发布
(config)#ip route 0.0.0.0 0.0.0.0 218.x.x.102
(config)#ip route 0.0.0.0 0.0.0.0 218.x.x.126
两条默认路由是自动起负载均衡;
This will do per-destination load-balancing. If per-packet load-balancing is needed, use "no ip route-cache" in interface mode to disable route cache.
teru 当前离线  
回复时引用此帖
旧 2004-04-16, 10:55   #50
ISIS
注册用户
级别:6 | 在线时长:69小时 | 升级还需:8小时级别:6 | 在线时长:69小时 | 升级还需:8小时
 
注册日期: Apr 2004
住址: liaoning
帖子: 22
现金:44金币
资产:44金币
声望力: 0
声望: 10 ISIS 向着好的方向发展
声望力: 0
ISIS 向着好的方向发展
启动CEF后在端口加 ip load-sharing per-packet, 不过回来的流量本方不能控制

interface FastEthernet0/1
ip address 2.2.2.2 255.255.255.0
no ip directed-broadcast
ip load-sharing per-packet
!
interface Serial1/0:0
ip address 1.1.1.1 255.255.255.252
no ip directed-broadcast
ip load-sharing per-packet
ISIS 当前离线  
回复时引用此帖
旧 2004-04-17, 09:52   #51
EVO
注册用户
级别:9 | 在线时长:117小时 | 升级还需:23小时级别:9 | 在线时长:117小时 | 升级还需:23小时级别:9 | 在线时长:117小时 | 升级还需:23小时级别:9 | 在线时长:117小时 | 升级还需:23小时级别:9 | 在线时长:117小时 | 升级还需:23小时
 
注册日期: Sep 2003
住址: 广西
帖子: 160
现金:320金币
资产:320金币
声望力: 16
声望: 10 EVO 向着好的方向发展
声望力: 16
EVO 向着好的方向发展
哪位高手能够将使用缺省路由实现负荷分担总结一下?这个帖子的确很好,但是有点太乱了。
EVO 当前离线  
回复时引用此帖
旧 2004-04-17, 10:58   #52
caojijun0
注册用户
级别:6 | 在线时长:63小时 | 升级还需:14小时级别:6 | 在线时长:63小时 | 升级还需:14小时
 
caojijun0 的头像
 
注册日期: Mar 2004
住址: 长沙
帖子: 39
现金:78金币
资产:78金币
声望力: 0
声望: 10 caojijun0 向着好的方向发展
声望力: 0
caojijun0 向着好的方向发展
有的协议是会支持自动选路的,如ospf

一个喜欢网络的人
caojijun0 当前离线  
回复时引用此帖
旧 2004-04-19, 02:05   #53
samhui
注册用户
级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时
 
samhui 的头像
 
注册日期: Sep 2003
住址: China
帖子: 117
现金:231金币
资产:231金币
声望力: 16
声望: 10 samhui 向着好的方向发展
声望力: 16
samhui 向着好的方向发展
把NAT放在router上做两出口可以吗?
samhui 当前离线  
回复时引用此帖
旧 2004-04-19, 11:18   #54
飞云
注册用户
级别:6 | 在线时长:67小时 | 升级还需:10小时级别:6 | 在线时长:67小时 | 升级还需:10小时
 
注册日期: Apr 2004
住址: 四川成都
帖子: 65
现金:130金币
资产:130金币
声望力: 15
声望: 10 飞云 向着好的方向发展
声望力: 15
飞云 向着好的方向发展
希望老大们,整理一下,提出一个既可行,又简单的办法,我是新手,头晕!!!!!!!
飞云 当前离线  
回复时引用此帖
旧 2004-04-19, 16:20   #55
sowan123
注册用户
级别:9 | 在线时长:128小时 | 升级还需:12小时级别:9 | 在线时长:128小时 | 升级还需:12小时级别:9 | 在线时长:128小时 | 升级还需:12小时级别:9 | 在线时长:128小时 | 升级还需:12小时级别:9 | 在线时长:128小时 | 升级还需:12小时
 
sowan123 的头像
 
注册日期: Oct 2003
住址: 南京
帖子: 254
现金:508金币
资产:508金币
声望力: 16
声望: 10 sowan123 向着好的方向发展
声望力: 16
sowan123 向着好的方向发展
作NAT转换时:
将内网部分地址(用10.10.10.0 255.255.255.0表示)对应 转换为61.61.61.1,
将内网其余部分地址(用10.20.20.0 255.255.255.0表示)对应转换为61.61.61.2:
PIX(config)#global (outside) 1 61.61.61.1 netmask 255.255.255.0
PIX(config)#nat (outside) 1 10.10.10.0 255.255.255.0
PIX(config)#global (outside) 2 61.61.61.2 netmask 255.255.255.0
PIX(config)#nat (outside) 2 10.20.20.0 255.255.255.0

在路由器中:
我觉得两条链路出口,应该兼有负载均衡和互为备份的能力。

track 123 ip host 218.x.x.102 reachability
track 124 ip host 218.x.x.126 reachability

ip policy route-map policy
route-map policy permit 10
match ip address 1
set ip next-hop verify-availability 218.x.x.102 track 123
set ip next-hop verify-availability 218.x.x.126 track 124
route-map policy permit 20
match ip address 2
set ip next-hop verify-availability 218.x.x.126 track 123
set ip next-hop verify-availability 218.x.x.102 track 124

此帖于 2004-04-19 16:27 被 sowan123 编辑。

无巧不成书
sowan123 当前离线  
回复时引用此帖
旧 2004-04-20, 16:55   #56
sunmoonsea
过路人
级别:12 | 在线时长:213小时 | 升级还需:8小时级别:12 | 在线时长:213小时 | 升级还需:8小时级别:12 | 在线时长:213小时 | 升级还需:8小时级别:12 | 在线时长:213小时 | 升级还需:8小时
 
sunmoonsea 的头像
 
注册日期: Jul 2003
住址: sz
帖子: 659
现金:1290金币
资产:1290金币
声望力: 16
声望: 10 sunmoonsea 向着好的方向发展
声望力: 16
sunmoonsea 向着好的方向发展
静态路由就可以实现负载均衡,将转换后的路由都指向两个对端。
不过我感觉从在某种问题
sunmoonsea 当前离线  
回复时引用此帖
旧 2004-04-21, 00:27   #57
samhui
注册用户
级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时
 
samhui 的头像
 
注册日期: Sep 2003
住址: China
帖子: 117
现金:231金币
资产:231金币
声望力: 16
声望: 10 samhui 向着好的方向发展
声望力: 16
samhui 向着好的方向发展
还有一个问题呀。。
如果没有VRRP的话。用策略路由,它不会看router table,如果端口不down时,数据包还是
会发到那个不能上网的端口上。
请问有什么方法呢?
samhui 当前离线  
回复时引用此帖
旧 2004-04-21, 12:57   #58
aron_wang
注册用户
级别:6 | 在线时长:61小时 | 升级还需:16小时级别:6 | 在线时长:61小时 | 升级还需:16小时
 
注册日期: Apr 2004
住址: 北京
帖子: 23
现金:45金币
资产:45金币
声望力: 0
声望: 10 aron_wang 向着好的方向发展
声望力: 0
aron_wang 向着好的方向发展
自动实现

楼主在例子里面再加一个指向防火墙的路由就可以自动实现负载分担。因为两个e口是轮询的方式
aron_wang 当前离线  
回复时引用此帖
旧 2004-04-21, 15:11   #59
binz
注册用户
级别:0 | 在线时长:3小时 | 升级还需:2小时
 
注册日期: Apr 2004
住址: 适合居住的城市
帖子: 3
现金:6金币
资产:6金币
声望力: 0
声望: 10 binz 向着好的方向发展
声望力: 0
binz 向着好的方向发展
出去的流量可以实现负载均衡,但进来的就不可以了
binz 当前离线  
回复时引用此帖
旧 2004-04-21, 23:42   #60
samhui
注册用户
级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时
 
samhui 的头像
 
注册日期: Sep 2003
住址: China
帖子: 117
现金:231金币
资产:231金币
声望力: 16
声望: 10 samhui 向着好的方向发展
声望力: 16
samhui 向着好的方向发展
引用:
最初由 binz 发布
出去的流量可以实现负载均衡,但进来的就不可以了
那有什么方法呢?
samhui 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 03:52


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号