Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
推荐为精华主题  
主题工具
旧 2004-08-17, 11:04   #61
xudy_99F
注册用户
级别:6 | 在线时长:75小时 | 升级还需:2小时级别:6 | 在线时长:75小时 | 升级还需:2小时
 
注册日期: Apr 2004
住址: 上海
帖子: 34
现金:68金币
资产:68金币
声望力: 0
声望: 10 xudy_99F 向着好的方向发展
声望力: 0
xudy_99F 向着好的方向发展
表面上看好像可以
实际上只是让一条链路起到了备份链路的作用,
楼主做的ip route map 真的起了作用了吗???
xudy_99F 当前离线  
回复时引用此帖
旧 2004-08-19, 00:27   #62
yiyingguo
注册用户
级别:6 | 在线时长:74小时 | 升级还需:3小时级别:6 | 在线时长:74小时 | 升级还需:3小时
 
注册日期: Jun 2004
住址: 广州
帖子: 147
现金:296金币
资产:296金币
声望力: 15
声望: 10 yiyingguo 向着好的方向发展
声望力: 15
yiyingguo 向着好的方向发展
在使用缺省路由的情况下:
第一,完全意义上的负载均衡应该只有PPPML才能实现,但是在这里是没有办法用PPPML的.这里可以用两条静态路由实现负载分担,但是,当其中一条路径上流量满了,还会不会再按照傻瓜式的方式,将新的会话继续使用这条已经满了的链路?
第二,支持 llongbo 兄弟:
第一种情况未必发生,因为其作的是两条匹配条件,最保靠的是可以
设为match ip add acc_id
match ip next-hop *.*。*。*
这样即使广域链路断了,仍可通过另一条链路通过,不会继续采用断路的nat了;若是不等带宽的广域链路的确不能做到负载分担,即使配成两条等价缺省路由通常也会采用最低带宽的负载分担,这样浪费了高带宽链路,是不可取的,不过港湾目前支持静态路由得不等价分担,类似eigrp不等带宽分担。
关于你说的第二种情况,不会发生,不同的isp不可能会把别人isp的网络路由到本自治域的。
第三,楼主的配置是单纯备份,而不是负载均衡.缺省路由的"Distance"应该是等于255,只有在缺省路由的"Distance"相同时,才可以实现浮动路由.
第四,如果将这个网络模型简化,内网用的是公网IP,不需要做NAT,那么楼主的配置可以简化为:
Router(Config)>int fa 0/0
Router(Config-if)>ip addr 公网地址及掩码
Router(Config-if)>no shut

/*接ISP1网口*/
Router(Config-if)>int fa 0/1
Router(Config-if)>ip addr 168.168.18.158 255.255.255.252
Router(Config-if)>no shut

/*接ISP2网口*/
Router(Config-if)>int s1/0
Router(Config-if)>ip addr 68.18.18.2 255.255.255.224
Router(Config-if)>no shut

设置浮动静态路由
Router(Config)>Ip Route 0.0.0.0 0.0.0.0 168.168.18.157
Router(Config)>Ip Route 0.0.0.0 0.0.0.0 68.18.18.1

---------------------错误处请大家指正.
yiyingguo 当前离线  
回复时引用此帖
旧 2004-09-06, 20:38   #63
everyday1700
注册用户
级别:6 | 在线时长:66小时 | 升级还需:11小时级别:6 | 在线时长:66小时 | 升级还需:11小时
 
注册日期: Jan 2004
住址: beijing
帖子: 5
现金:10金币
资产:10金币
声望力: 0
声望: 10 everyday1700 向着好的方向发展
声望力: 0
everyday1700 向着好的方向发展
是呀我也学觉得没有什么用,这个配置好象都route-map里好象作用不大,而且好象也起不到负载均衡的作用,不如配两个网段的访问列表在用route-map控制一个流量好用一些
everyday1700 当前离线  
回复时引用此帖
旧 2004-09-08, 13:45   #64
风很烈
注册用户
级别:8 | 在线时长:116小时 | 升级还需:1小时级别:8 | 在线时长:116小时 | 升级还需:1小时级别:8 | 在线时长:116小时 | 升级还需:1小时级别:8 | 在线时长:116小时 | 升级还需:1小时
 
风很烈 的头像
 
注册日期: May 2003
住址: 上海
帖子: 64
现金:128金币
资产:128金币
声望力: 16
声望: 10 风很烈 向着好的方向发展
声望力: 16
风很烈 向着好的方向发展
没错,我也遇到同样的问题! 客户要求DDN上网,ISDN做上网的备份;我写的配置NAT无法通,能帮我看看这个配置吗? 我马上就可以实验的,如果通了,我会告诉大家的!
Router# sh run
Building configuration...

Current configuration : 1237 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ftp-server write-enable
isdn switch-type basic-net3
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.240
ip nat inside
duplex auto
speed auto
!
interface Serial0/0
ip address 61.129.106.225 255.255.255.248
ip nat outside
backup interface BRI0/0
no fair-queue
!
interface BRI0/0
ip address negotiated
ip nat outside
encapsulation ppp
no ip split-horizon
dialer string 16300
dialer hold-queue 100
dialer-group 1
isdn switch-type basic-net3
no cdp enable
ppp authentication pap callin
ppp pap sent-username 16300 password 7 144644585C54
ppp multilink
!
ip nat inside source list 1 interface Serial0/0 overload
ip nat inside source list 2 interface BRI0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0/0
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip http server
!
access-list 1 permit any
access-list 2 permit any
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end

我先谢谢了;
风很烈 当前离线  
回复时引用此帖
旧 2004-09-17, 12:08   #65
kukul
注册用户
级别:10 | 在线时长:154小时 | 升级还需:11小时级别:10 | 在线时长:154小时 | 升级还需:11小时
 
kukul 的头像
 
注册日期: Jul 2003
住址: 广东
帖子: 274
现金:512金币
资产:512金币
声望力: 16
声望: 10 kukul 向着好的方向发展
声望力: 16
kukul 向着好的方向发展
要在ip route 0.0.0.0 0.0.0.0 BRI0/0后面加distance才能实现备份

UPDATE THE BRAIN EVERY DAY!!
kukul 当前离线  
回复时引用此帖
旧 2004-10-15, 16:36   #66
kkwzb
注册用户
级别:8 | 在线时长:114小时 | 升级还需:3小时级别:8 | 在线时长:114小时 | 升级还需:3小时级别:8 | 在线时长:114小时 | 升级还需:3小时级别:8 | 在线时长:114小时 | 升级还需:3小时
 
注册日期: Mar 2004
住址: 福建
帖子: 44
现金:106金币
资产:106金币
声望力: 0
声望: 10 kkwzb 向着好的方向发展
声望力: 0
kkwzb 向着好的方向发展
搞不懂这个配置的实际意义何在,郁闷~
kkwzb 当前离线  
回复时引用此帖
旧 2004-10-18, 15:46   #67
山水之间
注册用户
级别:1 | 在线时长:8小时 | 升级还需:4小时
 
山水之间 的头像
 
注册日期: Oct 2004
住址: 上海
帖子: 4
现金:8金币
资产:8金币
声望力: 0
声望: 10 山水之间 向着好的方向发展
声望力: 0
山水之间 向着好的方向发展
这个配置有问题啊

学习,学习,再学习!
山水之间 当前离线  
回复时引用此帖
旧 2004-10-18, 19:56   #68
kkwzb
注册用户
级别:8 | 在线时长:114小时 | 升级还需:3小时级别:8 | 在线时长:114小时 | 升级还需:3小时级别:8 | 在线时长:114小时 | 升级还需:3小时级别:8 | 在线时长:114小时 | 升级还需:3小时
 
注册日期: Mar 2004
住址: 福建
帖子: 44
现金:106金币
资产:106金币
声望力: 0
声望: 10 kkwzb 向着好的方向发展
声望力: 0
kkwzb 向着好的方向发展
是的,我反正是不明白,不知道大家明白了没有

就拿那个route-map来说吧,只匹配条件,却不指示符合条件的数据包的动作,搞不懂这有什么意义

其实按照作者所说的浮动静太路由,根本没有必要再写后面那些route-map呀~
kkwzb 当前离线  
回复时引用此帖
旧 2004-10-20, 10:18   #69
wjdlilin
注册用户
级别:8 | 在线时长:99小时 | 升级还需:18小时级别:8 | 在线时长:99小时 | 升级还需:18小时级别:8 | 在线时长:99小时 | 升级还需:18小时级别:8 | 在线时长:99小时 | 升级还需:18小时
 
注册日期: Nov 2003
住址: ddd
帖子: 87
现金:179金币
资产:179金币
声望力: 15
声望: 10 wjdlilin 向着好的方向发展
声望力: 15
wjdlilin 向着好的方向发展
根本不行
wjdlilin 当前离线  
回复时引用此帖
旧 2005-03-24, 12:53   #70
usr001
注册用户
级别:9 | 在线时长:127小时 | 升级还需:13小时级别:9 | 在线时长:127小时 | 升级还需:13小时级别:9 | 在线时长:127小时 | 升级还需:13小时级别:9 | 在线时长:127小时 | 升级还需:13小时级别:9 | 在线时长:127小时 | 升级还需:13小时
 
注册日期: Nov 2003
住址: 广州
帖子: 166
现金:396金币
资产:396金币
声望力: 15
声望: 10 usr001 向着好的方向发展
声望力: 15
usr001 向着好的方向发展
重新编辑了一下,加了一些必要说明
usr001 当前离线  
回复时引用此帖
旧 2005-03-28, 23:47   #71
ericlin
注册用户
级别:0 | 在线时长:1小时 | 升级还需:4小时
 
注册日期: Mar 2005
住址: 福建
帖子: 2
现金:4金币
资产:4金币
声望力: 0
声望: 10 ericlin 向着好的方向发展
声望力: 0
ericlin 向着好的方向发展
回复: 【原创】用route map实现多ISP Internet接入工程实例

这样的配置实现不料均衡,只能做到备份。

我以前也这样配置过,实际检验是不行的。
ericlin 当前离线  
回复时引用此帖
旧 2005-03-29, 14:32   #72
hbdos
注册用户
级别:5 | 在线时长:57小时 | 升级还需:3小时
 
注册日期: Jun 2004
住址: wuhan
帖子: 23
现金:54金币
资产:54金币
声望力: 0
声望: 10 hbdos 向着好的方向发展
声望力: 0
hbdos 向着好的方向发展
回复: 【原创】用route map实现多ISP Internet接入工程实例

好东西。
hbdos 当前离线  
回复时引用此帖
旧 2005-07-16, 09:15   #73
hwdhjb
注册用户
级别:0 | 在线时长:2小时 | 升级还需:3小时
 
注册日期: Jul 2005
住址: 珠海
帖子: 23
现金:46金币
资产:46金币
声望力: 0
声望: 10 hwdhjb 向着好的方向发展
声望力: 0
hwdhjb 向着好的方向发展
回复: 【原创】用route map实现多ISP Internet接入工程实例

网络技术群,诚招各路网络高手加入,一起探讨学习.群号:12500186
hwdhjb 当前离线  
回复时引用此帖
旧 2005-07-17, 07:16   #74
冬瓜头
俺就是那传说中的 冬瓜头
级别:23 | 在线时长:642小时 | 升级还需:30小时级别:23 | 在线时长:642小时 | 升级还需:30小时级别:23 | 在线时长:642小时 | 升级还需:30小时级别:23 | 在线时长:642小时 | 升级还需:30小时级别:23 | 在线时长:642小时 | 升级还需:30小时级别:23 | 在线时长:642小时 | 升级还需:30小时级别:23 | 在线时长:642小时 | 升级还需:30小时
 
冬瓜头 的头像
 
注册日期: May 2005
住址: 青岛人回青岛
帖子: 2,360
积分:11
精华:11
现金:5753金币
资产:5753金币
声望力: 17
声望: 119 冬瓜头 是将要出名的人啊冬瓜头 是将要出名的人啊
声望力: 17
冬瓜头 是将要出名的人啊冬瓜头 是将要出名的人啊
回复: 【原创】用route map实现多ISP Internet接入工程实例

楼主的子中,只要把两条缺省路由的优先级设为相同,就可以均衡,又可以备份,已经在cisco网站证实,
关于一条链路down掉究竟路由器是否还傻的用down掉的链路做nat,这个问题我认为不会.楼主这个配置的巧妙性关键就在于用了routemap映射做nat,其实路由器从内部到外部的包是先选路,后nat,既然down掉的链路在路由表里已经消失,那么路由就不会再选这条路,从而就无从match 已经down掉的出口,也就不会用这个口做nat了.

敝人专著,网络存储界的原创大作《大话存储-网络存储系统原理精解与最佳实践》,初学者的捷径!让你少奋斗2年!
这里是图书具体信息
点此购买《大话存储》
http://bbs.doit.com.cn/attachments/09082614006d3b3c6e3433a288.gif
QQ:122567712
MSN:myprotein0007@hotmail.com
email:myprotein@sina.com

欢迎光临敝人博客
帅哥 冬瓜头 当前离线  
回复时引用此帖
旧 2005-07-17, 22:30   #75
yewei0158
注册用户
级别:14 | 在线时长:278小时 | 升级还需:7小时级别:14 | 在线时长:278小时 | 升级还需:7小时级别:14 | 在线时长:278小时 | 升级还需:7小时级别:14 | 在线时长:278小时 | 升级还需:7小时级别:14 | 在线时长:278小时 | 升级还需:7小时级别:14 | 在线时长:278小时 | 升级还需:7小时
 
注册日期: Jan 2004
住址: 广西
帖子: 603
现金:1197金币
资产:1197金币
声望力: 15
声望: 10 yewei0158 向着好的方向发展
声望力: 15
yewei0158 向着好的方向发展
回复: 【原创】用route map实现多ISP Internet接入工程实例

楼上的女人说的没错。这里的route-map只是用来做nat的匹配条件。不是策略路由,也不需要指定set命令。两条链路的带宽不一样,做负载均衡没意义。备份的判断是路由器的链路down掉,如果是对端出现问题,路由器接口没有down,还是会继续走这路由。为了解决这问题,CISCO出了rtr这一精巧思路,track对端是否可达。
yewei0158 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 10:19


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号