Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
推荐为精华主题  
主题工具
旧 2004-05-12, 17:15   #46
winccie
注册用户
级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时级别:8 | 在线时长:104小时 | 升级还需:13小时
 
注册日期: Aug 2003
住址: 上海
帖子: 29
现金:52金币
资产:52金币
声望力: 0
声望: 10 winccie 向着好的方向发展
声望力: 0
winccie 向着好的方向发展
在泼点冷水
该版主所列的例子,从配置到说明都有问题,如果初学者按照他说得配置一定有问题,请大家还是不要盲目追随。至少我感觉版主配置的时候并没有把此网络规划好,想到哪里配哪里。
1、所配置的情况和说明的情况不一致,多处不一致,如果根据版主说得情况画拓扑图很明显的前后矛盾
2、vlan之间怎么通信?
3、作为多台交换设备在一起配置,没有vtp domain是不是太不完美
4、29上面配置的vlan1的地址能够和4006通信吗,在议
5、版主配置trunk allowed vlan 是不是可以在细致一些?

以上谨代表我个人意见!
winccie 当前离线  
回复时引用此帖
旧 2004-05-14, 16:40   #47
ancy
注册用户
级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时
 
注册日期: Oct 2003
住址: 广东
帖子: 1,204
积分:1
精华:1
现金:3128金币
资产:3128金币
声望力: 17
声望: 34 ancy 向着好的方向发展
声望力: 17
ancy 向着好的方向发展
spanning-tree extend system-id
no ip route-cache
no ip mroute-cache
上面这几条命令什么意思啊?
ancy 当前离线  
回复时引用此帖
旧 2004-05-14, 22:51   #48
大漠驼铃
注册用户
级别:0 | 在线时长:3小时 | 升级还需:2小时
 
大漠驼铃 的头像
 
注册日期: May 2004
住址: 北京
帖子: 16
现金:32金币
资产:32金币
声望力: 0
声望: 10 大漠驼铃 向着好的方向发展
声望力: 0
大漠驼铃 向着好的方向发展
如果加上acl就更好了,拓扑图差不多根据搂主的叙述应该理解差不多
大漠驼铃 当前离线  
回复时引用此帖
旧 2004-05-23, 17:13   #49
arlenhong
注册用户
级别:2 | 在线时长:16小时 | 升级还需:5小时级别:2 | 在线时长:16小时 | 升级还需:5小时
 
arlenhong 的头像
 
注册日期: May 2004
住址: gg
帖子: 13
现金:26金币
资产:26金币
声望力: 0
声望: 10 arlenhong 向着好的方向发展
声望力: 0
arlenhong 向着好的方向发展
支持Gladiator,斑竹误导新人啊!!

请新人不要看了,没有好的效果!
网络的规划出来,再到配置,vlan间的通讯是必不可少的,
最好有访问控制
arlenhong 当前离线  
回复时引用此帖
旧 2004-05-24, 22:41   #50
ancy
注册用户
级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时
 
注册日期: Oct 2003
住址: 广东
帖子: 1,204
积分:1
精华:1
现金:3128金币
资产:3128金币
声望力: 17
声望: 34 ancy 向着好的方向发展
声望力: 17
ancy 向着好的方向发展
大家看看什么不对的,请指出。谢谢!!!

经典的三层网络案例分析。改进中。。。新加很多先进技术噢!新增路由器的配置。
经典的三层网络案例分析。

目的:让不同的vlan 之间可以互相通讯。

IP规划
vlna ID ip网段 vlan网关
vlan 1 172.16.1.0/24 172.16.1.7-9
vlan 2 172.16.2.0/24 172.16.2.252-254
vlan 3 172.16.3.0/24 172.16.3.252-254
vlan 4 172.16.4.0/24 172.16.4.252-254
vlan 5 172.16.5.0/24 172.16.5.252-254
vlan 6 172.16.6.0/24 172.16.6.252-254
vlan 7 172.16.7.0/24 172.16.7.252-254
vlan 8 172.16.8.0/24 172.16.8.252-254
vlan 9 172.16.9.0/24 172.16.9.252-254
拓朴图见最后面



路由器配置

一、cisco路由器配置:
Enable
Configure terminal
Service password-encryption
Hostname cisco1721
Enable secret 654321
Enable password 123456
ip subnet-zero
ip name-server 202.96.134.133 202.96.172.218
interface fastethernet 0
ip address 61.142.221.5 255.255.255.240
speed auto
no shutdown
interface serial 0
ip unnumbered fastethernet 0
encapsulation ppp
no fair-queue
bandwidth 2048
no shutdown
exit
ip classless
ip route 0.0.0.0 0.0.0.0 serial 0
no ip http server
line con 0
line aux 0
line vty 0 4
password 12345678
login
no scheduler allocate
end
copy running-config startup-config
reload
请注意NAT等是在防火墙设置的.





交换机配置

一、Catalyst 4006-s3交换机配置:
Enable
Configure terminal
service pad
service password-encryption
hostname c4006-s3
enable password 123456.
Enable secret 654321
Ip subnet-zero
Ip name-server 172.16.8.1 172.16.8.2
ip routing
Exit
Vlan database
Vtp mode server
Vtp domain centervtp
Vlan 2 name vlan2
Vlan 3 name vlan3
Vlan 4 name vlan4
Vlan 5 name vlan5
Vlan 6 name vlan6
Vlan 7 name vlan7
Vlan 8 name vlan8
Vlan 9 name vlan9
Exit


Configure terminal
Interface port-channel 1
Interface gigabitethernet 2/1
channel-group 1
Interface gigabitethernet 2/2
channel-group 1
Interface gigabitethernet 2/1
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

interface gigabitethernet 2/3
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

interface gigabitethernet 2/4
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

interface gigbitethernet 2/5
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

interface gigbitethernet 2/6
switchport mode trunk
switchport trunk encapsulation dotlq
switchprot trunk allowed vlan all

interface gigbitethernet 2/7
switchport access vlan 9
no shutdown

interface range gigabitethernet 2/8 ? 20
switchport mode access
switchport access vlan 8
no shutdown
spanning-tree portfast

interface gigabitethernet 3/1
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

interface gigabitethernet 3/2
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

spanning-tree vlan 1-9 root primary
spanning-tree backbonefast

interface vlan 1
ip address 172.16.1.7 255.255.255.0
no shutdown
standby 1 ip 172.16.1.9
standby 1 priority 110 preempt

interface vlan 2
ip address 172.16.2.252 255.255.255.0
no shutdown
standby 2 ip 172.16.2.254
standby 2 priority 110 preempt
interface vlan 3
ip address 172.16.3.252 255.255.255.0
no shutdown
standby 3 ip 172.16.3.254
standby 3 priority 110 preempt

interface vlan 4
ip address 172.16.4.252 255.255.255.0
no shutdown
standby 4 ip 172.16.4.254
standby 4 priority 110 preempt

interface vlan 5
ip address 172.16.5.252 255.255.255.0
no shutdown
standby 5 ip 172.16.5.254
standby 5 priority 110 preempt

interface vlan 6
ip address 172.16.6.252 255.255.255.0
no shutdown
standby 6 ip 172.16.6.254
standby 6 priority 110 preempt

interface vlan 7
ip address 172.16.7.252 255.255.255.0
no shutdown
standby 7 ip 172.16.7.254
standby 7 priority 110 preempt

interface vlan 8
ip address 172.16.8.252 255.255.255.0
no shutdown
standby 8 ip 172.16.8.254
standby 8 priority 110 preempt

interface vlan 9
ip address 172.16.9.252 255.255.255.0
no shutdown
standby 9 ip 172.16.9.254
standby 9 priority 110 preempt

exit
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.9.250
line con 0
line aux 0
line vty 0 15
password 12345678
login
end
copy running-config startup-config
reload

































二、Catalyst 3550-12T交换机配置:
Enable
Configure terminal
service pad
service password-encryption
hostname c3550-12t
enable password 123456
enable secret 654321
ip subnet-zero
ip name-server 172.16.8.1. 172.16.8.2
ip routing
exit
vlan database
vtp mode server
vtp domain centervtp
vlan 2 name vlan2
vlan 3 name vlan3
vlan 4 name vlan4
vlan 5 name vlan5
vlan 6 name vlan6
vlan 7 name vlan7
vlan 8 name vlan8
vlan 9 name vlan9
exit


configure terminal
interface port-channel 1
interface gigabitethernet 0/1
channel-group 1
interface gigabitethernet 0/2
channel-group 1
exit

interface gigabitethernet 0/1
switchport mode trunk
switchport encapsulation dotlq
swithchport trunk allowed vlan all

interface gigabitethernet 0/3
switchport mode trunk
switchport trunk encapsulation dotlq
swithcport trunk allowed vlan all

interface gigabitethernet 0/4
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

interface gigabitethernet 0/5
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

interface gigabitethernet 0/6
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

interface gigabitethernet 0/7
switchport access vlan 9
no shutdown

interface range gigabitethernet 0/8 ? 10
switchport mode access
switchport access vlan 8
no shutdown
spanning-tree portfast

interface gigabitethernet 0/11
switchport mode trunk
switchport trunk encapsulation dotlq
swithcprot trunk allowed vlan all

interface gigabitethernet 0/12
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all

spanning-tree vlan 1-9 root secondary
spanning-tree backbonefast

interface vlan 1
ip address 172.16.1.8 255.255.255.0
no shutdown
standby 1 ip 172.16.1.9
standby 1 priority 100 preempt


interface vlan 2
ip address 172.16.2.253 255.255.255.0
no shutdown
standby 2 ip 172.16.2.254
standby 2 priority 100 preempt

interface vlan 3
ip address 172.16.3.253 255.255.255.0
not shutdown
standby 3 ip 172.16.3.254
standby 3 priority 100 preempt

interface vlan 4
ip address 172.16.4.253 255.255.255.0
no shutdown
standby 4 ip 172.16.4.254
standby 4 priority 100 preempt

interface vlan 5
ip addess 172.16.5.253 255.255.255.0
no shutdown
standby 5 ip 172.16.5.253
standby 5 priority 100 preempt

interface vlan 6
ip address 172.16.6.253 255.255.255.0
no shutdown
standby 6 ip 172.16.6.254
standby 6 priority 100 preempt

interface vlan 7
ip address 172.16.7.253 255.255.255.0
no shutdown
standby 7 ip 172.16.7.254
standby 7 priority 100 preempt

interface vlan 8
ip address 172.16.8.253 255.255.255.0
no shutdown
standby 8 ip 172.16.8.254
standby 8 priority 100 preempt

interface vlan 9
ip address 172.16.9.253 255.255.255.0
no shutdown
standby 9 ip 172.16.9.254
standby 9 priority 100 preempt

exit
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.9.250
ip http server
line con 0
line aux 0
line vty 0 15
password 12345678
login
end
copy running-config statup-config
reload






三、Catalyst 2950-24 vlan2 交换机配置:
Enable
Configure terminal
Service pad
Service password-encryption
Hostname c2950-241
Enable password 123456
Enable secret 654321
Ip subnet-zero
Interface vlan 1
Ip address 172.16.1.1 255.255.255.0
management
No shutdown
Ip default-gateway 172.16.1.9
Ip name-server 172.16.8.1 172.16.8.2
exit
Vlan database
Vtp mode client
Vtp domain centervtp
Exit
Configure terminal
Interface range fastethernet 0/1 ? 20
Switchport mode access
Switchport accesss vlan 2
No shutdown
Spanning-tree portfast

Spanning-tree uplinkfast
Spanning-tree backbonefast

Interface gigabitethernet 0/1
Switchport mode trunk
Switchport trunk encapculation dotlq
Switchport trunk allowed vlan all
Spanning-tree cost 10

Interface gigabitethernet 0/2
Switchport mode trunk
Switchport trunk encapculation dotlq
Switchport trunk allowed vlan all
Spanning-tree cost 20

Exit
Line con 0
Line aux 0
Line vty 0 15
Password 12345678
Login
End
Copy running-config statup-config
Reload







四、catalyst 2950-24 vlan 3 交换机配置:
enable
configure terminal
service pad
service password-encryption
hostname c2950-242
enable password 123456
enable secret 654321
ip subnet-zero
interface vlan 1
ip address 172.16.1.2 255.255.255.0
management
no shutdown
ip default-gateway 172.16.1.9
ip name-server 172.16.8.1 172.16.8.2
exit
vlan database
vtp domain centervtp
vtp mode client
exit

configure terminal
interface range fastethernet 0/1 ? 20
switchport mode access
switchport access vlan 3
no shutdown
spanning-tree portfast

spanning-tree uplinefast
spanning-tree backbonefast

interface gigabitethernet 0/1
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all
spanning-tree cost 10

interface gigabitethernet 0/2
switchport mode trunk
switchport trunk encapsulation dotlq
switchport trunk allowed vlan all
spanning-tree cost 20
exit

line con 0
line aux 0
line vty 0 15
password 12345678
login
end
copy running-config startup-config
reload


其它交换机配置类似。







有什么不对的对方大家指出来,共同进步。18 80

ancy 上传了这个图片:
http://bbs.net130.com/showthread.php?s=&threadid=48579

此帖于 2004-06-23 10:49 被 ancy 编辑。
ancy 当前离线  
回复时引用此帖
旧 2004-05-25, 08:19   #51
ancy
注册用户
级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时
 
注册日期: Oct 2003
住址: 广东
帖子: 1,204
积分:1
精华:1
现金:3128金币
资产:3128金币
声望力: 17
声望: 34 ancy 向着好的方向发展
声望力: 17
ancy 向着好的方向发展
怎么样才能把我的网络图上传上去啊
ancy 当前离线  
回复时引用此帖
旧 2004-06-04, 11:42   #52
lokyxz
注册用户
级别:0 | 在线时长:1小时 | 升级还需:4小时
 
lokyxz 的头像
 
注册日期: Jun 2004
住址: 广西
帖子: 1
现金:2金币
资产:2金币
声望力: 0
声望: 10 lokyxz 向着好的方向发展
声望力: 0
lokyxz 向着好的方向发展
别人问过的问题:

别人问过的问题:各VLAN间怎么互访?特别是上网的网关IP用哪个?
lokyxz 当前离线  
回复时引用此帖
旧 2004-06-04, 21:22   #53
ancy
注册用户
级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时级别:28 | 在线时长:925小时 | 升级还需:32小时
 
注册日期: Oct 2003
住址: 广东
帖子: 1,204
积分:1
精华:1
现金:3128金币
资产:3128金币
声望力: 17
声望: 34 ancy 向着好的方向发展
声望力: 17
ancy 向着好的方向发展
Re: 别人问过的问题:

引用:
最初由 lokyxz 发布
别人问过的问题:各VLAN间怎么互访?特别是上网的网关IP用哪个?
上面不是写了吗?
172.16.X.254啊
ancy 当前离线  
回复时引用此帖
旧 2004-06-10, 17:19   #54
yunhui_gao
注册用户
级别:3 | 在线时长:27小时 | 升级还需:5小时级别:3 | 在线时长:27小时 | 升级还需:5小时级别:3 | 在线时长:27小时 | 升级还需:5小时
 
yunhui_gao 的头像
 
注册日期: Jun 2004
住址: 江西南昌
帖子: 27
现金:36金币
资产:36金币
声望力: 0
声望: 10 yunhui_gao 向着好的方向发展
声望力: 0
yunhui_gao 向着好的方向发展
菜鸟虽不懂,但好帖子一定顶

珍藏。

网络尽在思科!
小小年纪就要调遍天下路由!

文明狼暂借使用!
yunhui_gao 当前离线  
回复时引用此帖
旧 2004-06-11, 08:09   #55
borui
注册用户
级别:0 | 在线时长:0小时 | 升级还需:5小时
 
borui 的头像
 
注册日期: Jun 2004
住址: 山东
帖子: 1
现金:2金币
资产:2金币
声望力: 0
声望: 10 borui 向着好的方向发展
声望力: 0
borui 向着好的方向发展
请问d-link des-3326如何设置镜像端口

我们单位安装了网路岗,需要设置镜像端口和分析端口,但是这两个名词我还是第一次听说,能详细的告诉我怎么设置吗?多谢!!!!
borui 当前离线  
回复时引用此帖
旧 2004-06-12, 11:25   #56
bigliuhai
注册用户
级别:3 | 在线时长:25小时 | 升级还需:7小时级别:3 | 在线时长:25小时 | 升级还需:7小时级别:3 | 在线时长:25小时 | 升级还需:7小时
 
bigliuhai 的头像
 
注册日期: Jun 2004
住址: 成都
帖子: 52
现金:106金币
资产:106金币
声望力: 15
声望: 10 bigliuhai 向着好的方向发展
声望力: 15
bigliuhai 向着好的方向发展
good
bigliuhai 当前离线  
回复时引用此帖
旧 2004-06-17, 09:30   #57
sailchow
注册用户
级别:5 | 在线时长:59小时 | 升级还需:1小时
 
sailchow 的头像
 
注册日期: Jun 2004
住址: 北京
帖子: 45
现金:88金币
资产:88金币
声望力: 0
声望: 10 sailchow 向着好的方向发展
声望力: 0
sailchow 向着好的方向发展
引用:
最初由 hu1981com 发布
按这样的配置各个vlan之间可以通信吗?怎么没有见到路由信息的配置,是不是通过S3自动实现路由的?如果要控制各个vlan之间的通信是不是必须用ACL来控制他们之间的访问?斑竹
是不是靠forwarding技术来转发它们之间的路由

金樽清酒斗十千,玉盘珍馐直万钱。
停杯投箸不能食,拔剑四顾心茫然。
欲渡黄河冰塞川,将登太行雪满山。
闲来垂钓坐溪上,忽复乘舟梦日边。
行路难,行路难,多歧路,今安在。
长风破浪会有时,直挂云帆济沧海。
sailchow 当前离线  
回复时引用此帖
旧 2004-06-17, 16:49   #58
sailskyline
无心无为
级别:14 | 在线时长:272小时 | 升级还需:13小时级别:14 | 在线时长:272小时 | 升级还需:13小时级别:14 | 在线时长:272小时 | 升级还需:13小时级别:14 | 在线时长:272小时 | 升级还需:13小时级别:14 | 在线时长:272小时 | 升级还需:13小时级别:14 | 在线时长:272小时 | 升级还需:13小时
 
sailskyline 的头像
 
注册日期: Apr 2004
住址: 合肥
帖子: 1,171
现金:2321金币
资产:2321金币
声望力: 16
声望: 16 sailskyline 向着好的方向发展
声望力: 16
sailskyline 向着好的方向发展
能给个拓扑图就好了!

If all the world hated you,
and you believed you to be wicked,
while your own conscience approval of you,
you could still hold up your head.


It's not violence that best conquers hate.
The good try is to love their enemies,
and bless those that curse them.
sailskyline 当前离线  
回复时引用此帖
旧 2004-06-21, 11:10   #59
dblfl
注册用户
级别:3 | 在线时长:27小时 | 升级还需:5小时级别:3 | 在线时长:27小时 | 升级还需:5小时级别:3 | 在线时长:27小时 | 升级还需:5小时
 
dblfl 的头像
 
注册日期: Mar 2004
住址: 吉林
帖子: 15
现金:30金币
资产:30金币
声望力: 0
声望: 10 dblfl 向着好的方向发展
声望力: 0
dblfl 向着好的方向发展
好东西一定要收藏

谢谢
dblfl 当前离线  
回复时引用此帖
旧 2004-06-21, 16:06   #60
zlconfident
注册用户
级别:0 | 在线时长:4小时 | 升级还需:1小时
 
注册日期: Jun 2004
住址: 北京
帖子: 20
现金:40金币
资产:40金币
声望力: 0
声望: 10 zlconfident 向着好的方向发展
声望力: 0
zlconfident 向着好的方向发展
还在讨论三层啊!知道的人太多了
zlconfident 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 03:54


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号