Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
 
主题工具
旧 2006-03-30, 18:50   #1
yelangdy
注册用户
级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时
 
注册日期: Jun 2005
住址: 北京
帖子: 116
现金:231金币
资产:231金币
声望力: 14
声望: 10 yelangdy 向着好的方向发展
声望力: 14
yelangdy 向着好的方向发展
问题 【求助】双出口+策略路由+链路互备

网络环境:两条20M光纤,各接一个路由器,再接到一个小的交换机上,再连到一台PIX525(四口)上,再到CISCO6500上。下有办公区,家属区。分到不同的VLAN 中。
要求:办公区和家属区,分别走不同的外线出去。同时外线要做到互相备份(冗余)。PIX用几个口没关系。

或者,用别的接法也行。只要能满足上面的要求。但至少要用到PIX,和一台路由器!!(可以个路由器加口)

急。!!
yelangdy 当前离线  
回复时引用此帖
旧 2006-03-30, 19:03   #2
yelangdy
注册用户
级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时
 
注册日期: Jun 2005
住址: 北京
帖子: 116
现金:231金币
资产:231金币
声望力: 14
声望: 10 yelangdy 向着好的方向发展
声望力: 14
yelangdy 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

有人知道吗??
yelangdy 当前离线  
回复时引用此帖
旧 2006-03-30, 19:08   #3
yelangdy
注册用户
级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时
 
注册日期: Jun 2005
住址: 北京
帖子: 116
现金:231金币
资产:231金币
声望力: 14
声望: 10 yelangdy 向着好的方向发展
声望力: 14
yelangdy 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

我自己顶!!!!!!!!!
这个问题我问了好几个群的人了,没人能说清。在网上找了好久,没有能同时实现的。。
yelangdy 当前离线  
回复时引用此帖
旧 2006-03-30, 20:31   #4
黑啤酒
注册用户
级别:6 | 在线时长:68小时 | 升级还需:9小时级别:6 | 在线时长:68小时 | 升级还需:9小时
 
注册日期: May 2005
住址: 北京
帖子: 235
现金:459金币
资产:459金币
声望力: 14
声望: 10 黑啤酒 向着好的方向发展
声望力: 14
黑啤酒 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

这个应该有多个方法实现。

两台路由器叫R1,R2。在65上做策略路由,下一跳分别是R1、R2,PIX用透明模式,在R1上配两条默认路由,一个指向本地连的外线,另一条指向R2,指向R2的路由metric设大些。同样R2也是类似的配法。这样家属用R1,办公用R2。R1外线断了,可以走R2。同理R2也是一样。
黑啤酒 当前离线  
回复时引用此帖
旧 2006-03-30, 21:46   #5
kind
注册用户
级别:13 | 在线时长:229小时 | 升级还需:23小时级别:13 | 在线时长:229小时 | 升级还需:23小时级别:13 | 在线时长:229小时 | 升级还需:23小时级别:13 | 在线时长:229小时 | 升级还需:23小时级别:13 | 在线时长:229小时 | 升级还需:23小时
 
注册日期: Sep 2003
住址: 南京
帖子: 265
现金:624金币
资产:624金币
声望力: 16
声望: 10 kind 向着好的方向发展
声望力: 16
kind 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

赞同,不过有实力就好了。看别人做过,自己没动手,顶
kind 当前离线  
回复时引用此帖
旧 2006-03-31, 10:20   #6
jackylea
注册用户
级别:13 | 在线时长:242小时 | 升级还需:10小时级别:13 | 在线时长:242小时 | 升级还需:10小时级别:13 | 在线时长:242小时 | 升级还需:10小时级别:13 | 在线时长:242小时 | 升级还需:10小时级别:13 | 在线时长:242小时 | 升级还需:10小时
 
jackylea 的头像
 
注册日期: May 2005
住址: 江苏
帖子: 265
现金:645金币
资产:645金币
声望力: 14
声望: 10 jackylea 向着好的方向发展
声望力: 14
jackylea 向着好的方向发展
问题 回复: 【求助】双出口+策略路由+链路互备

引用:
作者: 黑啤酒
这个应该有多个方法实现。

两台路由器叫R1,R2。在65上做策略路由,下一跳分别是R1、R2,PIX用透明模式,在R1上配两条默认路由,一个指向本地连的外线,另一条指向R2,指向R2的路由metric设大些。同样R2也是类似的配法。这样家属用R1,办公用R2。R1外线断了,可以走R2。同理R2也是一样。
好想法,利用浮动静态路由互做备份!pix上只做个nat,做几条静态路由,分别指向r1和r2,策列有65完成,不过实施起来有难度哦
jackylea 当前离线  
回复时引用此帖
旧 2006-03-31, 11:15   #7
zl5enter
注册用户
级别:0 | 在线时长:0小时 | 升级还需:5小时
 
注册日期: Mar 2006
住址: 北京
帖子: 11
现金:22金币
资产:22金币
声望力: 0
声望: 10 zl5enter 向着好的方向发展
声望力: 0
zl5enter 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

65上:
e0/0:ip address 10.10.0.254 255.255.255.0
e0/1: ip address 10.10.1.254 255.255.255.0
vlan 1 (management)
10.10.100.253 255.255.255.0
vlan 10
10.10.0.253 255.255.255.0
vlan 20
ip address 10.10.1.1 255.255.255.0

ip routing

26-1:
e0/0:
ip address 10.10.0.2 255.255.255.0
standby 1 ip 10.10.0.1
standby 1 priority 105
standby 1 preempt
standby 2 ip 10.10.10.1
standby 2 preempt

s0/0
ip address 192.168.250.1 255.255.255.252

ip route 0.0.0.0 0.0.0.0 192.168.250.1

26-2:
e0/0:
ip address 10.10.0.3 255.255.255.0
standby 1 preempt
standby 1 ip 10.10.0.1
standby 2 ip 10.10.10.2
standby 2 priority 105 preempt

s0/0:
192.168.248.1 255.255.255.252

ip route 0.0.0.0 0.0.0.0 192.168.248.2
zl5enter 当前离线  
回复时引用此帖
旧 2006-03-31, 11:17   #8
zl5enter
注册用户
级别:0 | 在线时长:0小时 | 升级还需:5小时
 
注册日期: Mar 2006
住址: 北京
帖子: 11
现金:22金币
资产:22金币
声望力: 0
声望: 10 zl5enter 向着好的方向发展
声望力: 0
zl5enter 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

好像不对,大家一起改改吧,我大概是这个思路。
zl5enter 当前离线  
回复时引用此帖
旧 2006-03-31, 11:35   #9
sd5193387
注册用户
级别:5 | 在线时长:49小时 | 升级还需:11小时
 
注册日期: Mar 2006
住址: 北京
帖子: 54
现金:108金币
资产:108金币
声望力: 13
声望: 10 sd5193387 向着好的方向发展
声望力: 13
sd5193387 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

HSRP 应该可以啊!!!
新手!
sd5193387 当前离线  
回复时引用此帖
旧 2006-03-31, 11:42   #10
liuxuewu21
注册用户
级别:12 | 在线时长:209小时 | 升级还需:12小时级别:12 | 在线时长:209小时 | 升级还需:12小时级别:12 | 在线时长:209小时 | 升级还需:12小时级别:12 | 在线时长:209小时 | 升级还需:12小时
 
liuxuewu21 的头像
 
注册日期: Sep 2005
住址: 宁夏
帖子: 434
现金:903金币
资产:903金币
声望力: 14
声望: 10 liuxuewu21 向着好的方向发展
声望力: 14
liuxuewu21 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

我的想法是两路由器做VRRP或者HSRP 然后连个防火墙(做策略也可以不做也可以)然后交换机 然后两个地方,如果做浮动路由

一个错误存在着,如果用另一个错误去修补,只会错上加错 !
liuxuewu21 当前离线  
回复时引用此帖
旧 2006-03-31, 11:45   #11
liuxuewu21
注册用户
级别:12 | 在线时长:209小时 | 升级还需:12小时级别:12 | 在线时长:209小时 | 升级还需:12小时级别:12 | 在线时长:209小时 | 升级还需:12小时级别:12 | 在线时长:209小时 | 升级还需:12小时
 
liuxuewu21 的头像
 
注册日期: Sep 2005
住址: 宁夏
帖子: 434
现金:903金币
资产:903金币
声望力: 14
声望: 10 liuxuewu21 向着好的方向发展
声望力: 14
liuxuewu21 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

我的想法是两路由器做VRRP或者HSRP 然后连个防火墙(做策略也可以不做也可以)然后交换机 然后两个地方,如果一个断了另个马上起来
对接入两个小区分别走两个不同线路那就走浮动路由,
有不对的地方希望指出
liuxuewu21 当前离线  
回复时引用此帖
旧 2006-03-31, 11:47   #12
liuxuewu21
注册用户
级别:12 | 在线时长:209小时 | 升级还需:12小时级别:12 | 在线时长:209小时 | 升级还需:12小时级别:12 | 在线时长:209小时 | 升级还需:12小时级别:12 | 在线时长:209小时 | 升级还需:12小时
 
liuxuewu21 的头像
 
注册日期: Sep 2005
住址: 宁夏
帖子: 434
现金:903金币
资产:903金币
声望力: 14
声望: 10 liuxuewu21 向着好的方向发展
声望力: 14
liuxuewu21 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

ip access-list 110 permit 192.168.1.0 0.0.0.255 any
ip access-list 100 permit 192.168.2.0 0.0.0.255 any
route-map filter 1 permit 10
match ip interface e0
match ip address 110
set ip next-hop ge0/1(网通)
route-map filter 1 permit 20
match ip interface e1
match ip address 120
set ip next-hop ge0/1(电信)
route-map filter 1 permit 30

ip local policy-map route-map filter
假设E0对应的网络是网通的:192.168.1.0
假设E1对应的网络是电信的:192.168.2.0
我做过实验在同台路由器上可以做的
liuxuewu21 当前离线  
回复时引用此帖
旧 2006-03-31, 15:04   #13
yelangdy
注册用户
级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时
 
注册日期: Jun 2005
住址: 北京
帖子: 116
现金:231金币
资产:231金币
声望力: 14
声望: 10 yelangdy 向着好的方向发展
声望力: 14
yelangdy 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

感谢大家的回复。问提是:6楼的方法可行,但PIX不能升级。无法支持透明模式。
11楼的方法。无法实现切换
yelangdy 当前离线  
回复时引用此帖
旧 2006-03-31, 15:09   #14
yelangdy
注册用户
级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时级别:4 | 在线时长:32小时 | 升级还需:13小时
 
注册日期: Jun 2005
住址: 北京
帖子: 116
现金:231金币
资产:231金币
声望力: 14
声望: 10 yelangdy 向着好的方向发展
声望力: 14
yelangdy 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

各位大虾们有没有更好的方法??
yelangdy 当前离线  
回复时引用此帖
旧 2006-03-31, 16:22   #15
ponecn
注册用户
级别:5 | 在线时长:47小时 | 升级还需:13小时
 
ponecn 的头像
 
注册日期: Jun 2005
住址: NJ
帖子: 119
现金:217金币
资产:217金币
声望力: 14
声望: 10 ponecn 向着好的方向发展
声望力: 14
ponecn 向着好的方向发展
回复: 【求助】双出口+策略路由+链路互备

关注

CISCO PR QQ:31924601
MSN:Ponecn*hotmail.com
E-mail:xiaoyu-cw*163.com
渠道群:5300344 内含报价!
帅哥 ponecn 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 12:02


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号