Cisco网络技术论坛

返回   Cisco网络技术论坛 > 综合区 > 其他计算机类认证考试 > ITAA认证

发表新主题 回复
 
主题工具
旧 2008-02-16, 15:42   #1
ITAA工程师
注册用户
级别:0 | 在线时长:4小时 | 升级还需:1小时
 
注册日期: Nov 2007
住址: 天津
帖子: 34
现金:105金币
资产:105金币
声望力: 0
声望: 10 ITAA工程师 向着好的方向发展
声望力: 0
ITAA工程师 向着好的方向发展
实验:浮动静态路由

实验:浮动静态路由



在看np的高级路由的时候书中有一个浮动静态路由的实验,我用远程的台子做了一下这个实验。



拓扑图



(r2)
/
/ ;
/ ;
(r1)--------(r3)



r1 s1/0:1.1.1.1/24 s2/0:10.1.1.1/24



r2 s1/0:2.2.2.2/24 s2/0:1.1.1.2/24



r3 s1/0:10.1.1.3/24 s2/0:2.2.2.3/24



配置如下:



r1



hostname 1
!
interface Serial1/0
ip address 1.1.1.1 255.255.255.0
clockrate 64000
!
interface Serial2/0
ip address 10.1.1.1 255.255.255.0
!
ip route 2.0.0.0 255.0.0.0 10.1.1.3



r2



hostname 2
!
interface Serial1/0
ip address 2.2.2.2 255.255.255.0
clockrate 64000
!
interface Serial2/0
ip address 1.1.1.2 255.255.255.0
!
ip route 10.0.0.0 255.0.0.0 1.1.1.1
ip route 10.0.0.0 255.0.0.0 2.2.2.3 10 /手动添加的一条浮动路由,管理距离为10/



r3



hostname 3
!
interface Serial1/0
ip address 10.1.1.3 255.255.255.0
clockrate 64000
!
interface Serial2/0
ip address 2.2.2.3 255.255.255.0
!
ip classless
ip route 1.0.0.0 255.0.0.0 10.1.1.1



我从r2上ping10.1.1.3,为了更好的看效果我添加了访问控制列表。



r2的路由表:
2#show ip route



1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Serial2/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Serial1/0
S 10.0.0.0/8 [1/0] via 1.1.1.1
2(config)#access-list 101 permit ip host 1.1.1.2 host 10.1.1.3
2(config)#access-list 101 permit ip any
2#debug ip pac 101
debug输出为:
*Jul 28 06:51:20.367: IP: s=1.1.1.2 (local), d=10.1.1.3 (Serial2/0), len 100, sending
*Jul 28 06:51:20.407: IP: s=10.1.1.3 (Serial2/0), d=1.1.1.2 (Serial2/0), len 100, rcvd 3
*Jul 28 06:51:20.407: ICMP: echo reply rcvd, src 10.1.1.3, dst 1.1.1.2
*Jul 28 06:51:20.435: IP: s=1.1.1.2 (local), d=10.1.1.3 (Serial2/0), len 100, sending
*Jul 28 06:51:20.475: IP: s=10.1.1.3 (Serial2/0), d=1.1.1.2 (Serial2/0), len 100, rcvd 3
*Jul 28 06:51:20.475: ICMP: echo reply rcvd, src 10.1.1.3, dst 1.1.1.2
*Jul 28 06:51:20.487: IP: s=1.1.1.2 (local), d=10.1.1.3 (Serial2/0), len 100, sending
*Jul 28 06:51:20.527: IP: s=10.1.1.3 (Serial2/0), d=1.1.1.2 (Serial2/0), len 100, rcvd 3
*Jul 28 06:51:20.527: ICMP: echo reply rcvd, src 10.1.1.3, dst 1.1.1.2
*Jul 28 06:51:20.547: IP: s=1.1.1.2 (local), d=10.1.1.3 (Serial2/0), len 100, sending
*Jul 28 06:51:20.595: IP: s=10.1.1.3 (Serial2/0), d=1.1.1.2 (Serial2/0), len 100, rcvd 3
*Jul 28 06:51:20.595: ICMP: echo reply rcvd, src 10.1.1.3, dst 1.1.1.2
*Jul 28 06:51:20.615: IP: s=1.1.1.2 (local), d=10.1.1.3 (Serial2/0), len 100, sending
*Jul 28 06:51:20.675: IP: s=10.1.1.3 (Serial2/0), d=1.1.1.2 (Serial2/0), len 100, rcvd 3
*Jul 28 06:51:20.675: ICMP: echo reply rcvd, src 10.1.1.3, dst 1.1.1.2
注意到是从s2/0出去的.



现在我们在r1上把s1/0shutdown掉



r2的路由表:
2#show ip route
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Serial1/0
S 10.0.0.0/8 [10/0] via 2.2.2.3



r2上的访问控制列表为:
2(config)#access-list 102 permit ip host 1.1.1.2 host 10.1.1.3
2(config)#access-list 102 permit ip any
2#debug ip pac 102
debug输出为:
*Jul 28 06:58:22.775: IP: s=2.2.2.2 (local), d=10.1.1.3 (Serial1/0), len 100, sending
*Jul 28 06:58:22.815: IP: s=10.1.1.3 (Serial1/0), d=2.2.2.2 (Serial1/0), len 100, rcvd 3
*Jul 28 06:58:22.815: ICMP: echo reply rcvd, src 10.1.1.3, dst 2.2.2.2
*Jul 28 06:58:22.847: IP: s=2.2.2.2 (local), d=10.1.1.3 (Serial1/0), len 100, sending
*Jul 28 06:58:22.887: IP: s=10.1.1.3 (Serial1/0), d=2.2.2.2 (Serial1/0), len 100, rcvd 3
*Jul 28 06:58:22.887: ICMP: echo reply rcvd, src 10.1.1.3, dst 2.2.2.2
*Jul 28 06:58:22.907: IP: s=2.2.2.2 (local), d=10.1.1.3 (Serial1/0), len 100, sending
*Jul 28 06:58:22.947: IP: s=10.1.1.3 (Serial1/0), d=2.2.2.2 (Serial1/0), len 100, rcvd 3
*Jul 28 06:58:22.947: ICMP: echo reply rcvd, src 10.1.1.3, dst 2.2.2.2
*Jul 28 06:58:22.955: IP: s=2.2.2.2 (local), d=10.1.1.3 (Serial1/0), len 100, sending
*Jul 28 06:58:23.007: IP: s=10.1.1.3 (Serial1/0), d=2.2.2.2 (Serial1/0), len 100, rcvd 3
*Jul 28 06:58:23.007: ICMP: echo reply rcvd, src 10.1.1.3, dst 2.2.2.2
*Jul 28 06:58:23.015: IP: s=2.2.2.2 (local), d=10.1.1.3 (Serial1/0), len 100, sending
*Jul 28 06:58:23.067: IP: s=10.1.1.3 (Serial1/0), d=2.2.2.2 (Serial1/0), len 100, rcvd 3
*Jul 28 06:58:23.067: ICMP: echo reply rcvd, src 10.1.1.3, dst 2.2.2.2



可以看出ping是从s1/0出去的,说明了浮动路由起了作用.
ITAA工程师 当前离线  
回复时引用此帖
旧 2012-06-11, 22:15   #2
vbnsaa
注册用户
级别:0 | 在线时长:3小时 | 升级还需:2小时
 
注册日期: Sep 2011
帖子: 54
现金:162金币
资产:162金币
声望力: 8
声望: 10 vbnsaa 向着好的方向发展
声望力: 8
vbnsaa 向着好的方向发展
回复: 实验:浮动静态路由

在公司用了款美~信CreCloud云网管,挺不错的,属于云计算技术理念和IT监控技术的完美结合,云网管的成功开发和应用,使云计算理念在IT监控领域落地,而且还是永久免费。http://www.mxsoft.com
帅哥 vbnsaa 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 11:11


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号