Cisco网络技术论坛

返回   Cisco网络技术论坛 > Cisco专区 > Cisco技术高级讨论区

Cisco技术高级讨论区 讨论Cisco较深和较全面的问题,此栏目帖子是从cisco技术区选出,由斑竹移到此区,不能发贴,可以跟贴

发表新主题 回复
推荐为精华主题  
主题工具
旧 2004-03-14, 16:44   #1
anny
注册用户
级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时
 
anny 的头像
 
注册日期: Jun 2003
住址: 江西南昌
帖子: 138
现金:267金币
资产:267金币
声望力: 16
声望: 10 anny 向着好的方向发展
声望力: 16
anny 向着好的方向发展
网关指向核心交换机(4506),上网速度奇慢!

某企业网核心为4506,接入基本为2950系列。核心有一块X 4548 GB -RJ业务板,其中48口上联到防火墙,其他下联到客户端。客户端网关指向核心交换机,上网速度奇慢。指向防火墙则速度正常,防火墙地址为172。16。1。1 核心配置如下:


core_switch#show run
Building configuration...

Current configuration : 6061 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname core_switch
!
enable secret 5 $1$21p4$rcisbziyY7iFWx0w7jm6d.
enable password kindy
!
vtp mode transparent
ip subnet-zero
!
spanning-tree extend system-id
!
!
vlan 2
name vlan2
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
description To ZXC
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet2/2
description To HYS-310
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet2/3
description To HYS-303
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet2/4
description To PGZ
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet2/5
description To WLZ
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet2/6
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/1
description To BACK_24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
!
interface GigabitEthernet3/6
!
interface GigabitEthernet4/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/4
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/5
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/6
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/7
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/8
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/9
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/10
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/11
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/12
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/13
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/14
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/15
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/16
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/17
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/18
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/19
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/20
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/21
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/22
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/23
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/25
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/26
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/27
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/28
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/29
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/30
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/31
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/32
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/33
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/34
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/35
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/36
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/37
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/38
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/39
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/40
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/41
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/42
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/43
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/44
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/45
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/46
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/47
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet4/48
!
interface Vlan1
ip address 172.16.1.121 255.255.255.0
!
interface Vlan2
ip address 172.16.2.1 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.1
no ip http server
!
!
!
!
line con 0
password ******
login
stopbits 1
line vty 0 4
password ******
login
!
end
anny 当前离线  
回复时引用此帖
旧 2004-03-14, 23:16   #2
teru
超级版主
级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时级别:34 | 在线时长:1295小时 | 升级还需:70小时
 
teru 的头像
 
注册日期: May 2003
住址: macau
帖子: 3,487
现金:6918金币
资产:6918金币
声望力: 19
声望: 23 teru 向着好的方向发展
声望力: 19
teru 向着好的方向发展
Try if it works:

int vlan 1
no ip redirects
teru 当前离线  
回复时引用此帖
旧 2004-03-15, 12:26   #3
winniw
注册用户
级别:7 | 在线时长:88小时 | 升级还需:8小时级别:7 | 在线时长:88小时 | 升级还需:8小时级别:7 | 在线时长:88小时 | 升级还需:8小时
 
winniw 的头像
 
注册日期: Mar 2004
住址: 辽宁
帖子: 151
现金:302金币
资产:302金币
声望力: 15
声望: 10 winniw 向着好的方向发展
声望力: 15
winniw 向着好的方向发展
能说说为什么吗?
详细解释一下这条命令,什么时候需要加,什么时候不需要加。

winniw 当前离线  
回复时引用此帖
旧 2004-03-15, 14:02   #4
anny
注册用户
级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时级别:9 | 在线时长:134小时 | 升级还需:6小时
 
anny 的头像
 
注册日期: Jun 2003
住址: 江西南昌
帖子: 138
现金:267金币
资产:267金币
声望力: 16
声望: 10 anny 向着好的方向发展
声望力: 16
anny 向着好的方向发展
teru
超级版主
谢谢你!这条命令很爽啊!!!!!问题解决了.再次谢谢!!!!
anny 当前离线  
回复时引用此帖
旧 2004-03-16, 15:32   #5
buaaycb
注册用户
级别:5 | 在线时长:52小时 | 升级还需:8小时
 
注册日期: Mar 2004
住址: 北京
帖子: 2
现金:4金币
资产:4金币
声望力: 0
声望: 10 buaaycb 向着好的方向发展
声望力: 0
buaaycb 向着好的方向发展
请问兄弟,你的客户端用的是什么系统?
buaaycb 当前离线  
回复时引用此帖
旧 2004-03-31, 20:40   #6
cobel
注册用户
级别:10 | 在线时长:143小时 | 升级还需:22小时级别:10 | 在线时长:143小时 | 升级还需:22小时
 
cobel 的头像
 
注册日期: Apr 2003
住址: 北京
帖子: 164
现金:328金币
资产:328金币
声望力: 16
声望: 10 cobel 向着好的方向发展
声望力: 16
cobel 向着好的方向发展
偶虽然还没想明白,不过已死记硬背了!
cobel 当前离线  
回复时引用此帖
旧 2004-04-01, 10:39   #7
兔八哥
注册用户
级别:6 | 在线时长:64小时 | 升级还需:13小时级别:6 | 在线时长:64小时 | 升级还需:13小时
 
兔八哥 的头像
 
注册日期: Apr 2004
住址: 浙江
帖子: 38
现金:75金币
资产:75金币
声望力: 0
声望: 10 兔八哥 向着好的方向发展
声望力: 0
兔八哥 向着好的方向发展
能不能做进一不的解释啊?
我们的很多交换机上都有这个配置!
表面意思理解:
禁止做IP重定向
但是有些不好理解,请教各位高手!
兔八哥 当前离线  
回复时引用此帖
旧 2004-04-02, 15:05   #8
yboonj
注册用户
级别:6 | 在线时长:60小时 | 升级还需:17小时级别:6 | 在线时长:60小时 | 升级还需:17小时
 
yboonj 的头像
 
注册日期: Mar 2004
住址: 南京
帖子: 11
现金:22金币
资产:22金币
声望力: 0
声望: 10 yboonj 向着好的方向发展
声望力: 0
yboonj 向着好的方向发展
斑竹就是斑竹
yboonj 当前离线  
回复时引用此帖
旧 2004-04-11, 16:50   #9
zcy7773
注册用户
级别:8 | 在线时长:96小时 | 升级还需:21小时级别:8 | 在线时长:96小时 | 升级还需:21小时级别:8 | 在线时长:96小时 | 升级还需:21小时级别:8 | 在线时长:96小时 | 升级还需:21小时
 
zcy7773 的头像
 
注册日期: Mar 2004
住址: 111111
帖子: 160
现金:328金币
资产:328金币
声望力: 15
声望: 10 zcy7773 向着好的方向发展
声望力: 15
zcy7773 向着好的方向发展
no ip redirects
是什么意思呀.
zcy7773 当前离线  
回复时引用此帖
旧 2004-04-11, 22:49   #10
slopover
注册用户
级别:10 | 在线时长:145小时 | 升级还需:20小时级别:10 | 在线时长:145小时 | 升级还需:20小时
 
注册日期: Apr 2003
住址: 福州
帖子: 125
现金:245金币
资产:245金币
声望力: 16
声望: 10 slopover 向着好的方向发展
声望力: 16
slopover 向着好的方向发展
no ip redirects
把重定向关了
建议在实际工程中不使用VLAN1 这玩意太坏了 全网乱跑

http://bbs.net130.com/attachment.php?s=4fa0991df56c906fdea3b282ffc58b7a&postid=124966
slopover 当前离线  
回复时引用此帖
旧 2004-04-12, 11:27   #11
skyxy
注册用户
级别:5 | 在线时长:55小时 | 升级还需:5小时
 
skyxy 的头像
 
注册日期: Jan 2004
住址: 合肥
帖子: 11
现金:22金币
资产:22金币
声望力: 0
声望: 10 skyxy 向着好的方向发展
声望力: 0
skyxy 向着好的方向发展
ip redirect是ICMP协议中规定的一种状态,在此例中所有的数据包都要通过172.16.1.121再转发给防火墙172.16.1.1,121发现1以及所有的客户机都在一个网段内,121就会给客户机发出icmp redirect报文,告诉客户机往外访问的下一跳地址指向172.16.1.1,如果客户机是UNIX操作系统(我试过linux和Sco UNIX),操作系统会自动在主机路由表中加入这个信息,这样客户机就不必通过172.16.1.121来转发数据包了。但Windows主机好像无此功能,所以就造成了主交换机不断给客户机发icmp redirect报文,导致了整个系统很慢。这是我的看法,希望和大家共同讨论!
skyxy 当前离线  
回复时引用此帖
旧 2004-04-12, 23:09   #12
超级口水猫
注册用户
级别:6 | 在线时长:61小时 | 升级还需:16小时级别:6 | 在线时长:61小时 | 升级还需:16小时
 
注册日期: Apr 2004
住址: hu nang
帖子: 7
现金:14金币
资产:14金币
声望力: 0
声望: 10 超级口水猫 向着好的方向发展
声望力: 0
超级口水猫 向着好的方向发展
k

这里有ip redirect的解释When Are ICMP Redirects Sent?
http://www.cisco.com/warp/public/556/5.html
很奇怪
我觉得防火墙与多层交换机的vlan1不在同一个网段
就不会出现这个问题了
但是这里防炎墙与 vlan1 在同一个网段
而最终出口是同防火墙出去
所以ip redirect 会起作用
但还是出现问题了
楼上说的的确有些道理
问题应该是主机上出现的
但是否肯定呢?
能否拿出更能说明问题的论据
超级口水猫 当前离线  
回复时引用此帖
旧 2004-04-14, 11:17   #13
soniczhu
注册用户
级别:5 | 在线时长:49小时 | 升级还需:11小时
 
注册日期: Apr 2004
住址: 广东深圳
帖子: 7
现金:14金币
资产:14金币
声望力: 0
声望: 10 soniczhu 向着好的方向发展
声望力: 0
soniczhu 向着好的方向发展
我也出现了类似问题,

我也出现了类似问题,我有四台45交换机,这里有五十个VLAN,我把两个,两个为一组来做分担,但是我发现直接与Internet 出口路由器相接的交换机上网快,但是另一组很慢.最后我都移到另一组上了.到现在原因不明.我做了(HSRP)

索尼克
soniczhu 当前离线  
回复时引用此帖
旧 2004-04-14, 11:38   #14
skyxy
注册用户
级别:5 | 在线时长:55小时 | 升级还需:5小时
 
skyxy 的头像
 
注册日期: Jan 2004
住址: 合肥
帖子: 11
现金:22金币
资产:22金币
声望力: 0
声望: 10 skyxy 向着好的方向发展
声望力: 0
skyxy 向着好的方向发展
大家如果对ICMP Redirect感兴趣,可以参见Richard Stevens所著的《Tcp Illustrated》第一本书第9章,上面描述的很清楚!
skyxy 当前离线  
回复时引用此帖
旧 2004-04-15, 10:15   #15
whecs
注册用户
级别:3 | 在线时长:21小时 | 升级还需:11小时级别:3 | 在线时长:21小时 | 升级还需:11小时级别:3 | 在线时长:21小时 | 升级还需:11小时
 
注册日期: Apr 2004
住址: wuhan
帖子: 2
现金:4金币
资产:4金币
声望力: 0
声望: 10 whecs 向着好的方向发展
声望力: 0
whecs 向着好的方向发展
现在一般默认是重定向关闭的
whecs 当前离线  
回复时引用此帖
发表新主题 回复

主题工具

发帖规则
不可以发表新主题
不可以发表回复
不可以上传附件
不可以编辑自己的帖子

启用 BB 代码
论坛启用 表情符号
论坛启用 [IMG] 代码
论坛禁用 HTML 代码

论坛跳转


所有时间均为北京时间。现在的时间是 08:01


Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号