Cisco网络技术论坛

Cisco网络技术论坛 (http://bbs.net130.com/index.php)
-   Cisco技术高级讨论区 (http://bbs.net130.com/forumdisplay.php?f=17)
-   -   【求助】双出口+策略路由+链路互备 (http://bbs.net130.com/showthread.php?t=139929)

yelangdy 2006-03-30 18:50

【求助】双出口+策略路由+链路互备
 
网络环境:两条20M光纤,各接一个路由器,再接到一个小的交换机上,再连到一台PIX525(四口)上,再到CISCO6500上。下有办公区,家属区。分到不同的VLAN 中。
要求:办公区和家属区,分别走不同的外线出去。同时外线要做到互相备份(冗余)。PIX用几个口没关系。

或者,用别的接法也行。只要能满足上面的要求。但至少要用到PIX,和一台路由器!!(可以个路由器加口)

急。!!

yelangdy 2006-03-30 19:03

回复: 【求助】双出口+策略路由+链路互备
 
有人知道吗??

yelangdy 2006-03-30 19:08

回复: 【求助】双出口+策略路由+链路互备
 
我自己顶!!!!!!!!!
这个问题我问了好几个群的人了,没人能说清。在网上找了好久,没有能同时实现的。。

黑啤酒 2006-03-30 20:31

回复: 【求助】双出口+策略路由+链路互备
 
这个应该有多个方法实现。

两台路由器叫R1,R2。在65上做策略路由,下一跳分别是R1、R2,PIX用透明模式,在R1上配两条默认路由,一个指向本地连的外线,另一条指向R2,指向R2的路由metric设大些。同样R2也是类似的配法。这样家属用R1,办公用R2。R1外线断了,可以走R2。同理R2也是一样。

kind 2006-03-30 21:46

回复: 【求助】双出口+策略路由+链路互备
 
赞同,不过有实力就好了。看别人做过,自己没动手,顶

jackylea 2006-03-31 10:20

回复: 【求助】双出口+策略路由+链路互备
 
引用:

作者: 黑啤酒
这个应该有多个方法实现。

两台路由器叫R1,R2。在65上做策略路由,下一跳分别是R1、R2,PIX用透明模式,在R1上配两条默认路由,一个指向本地连的外线,另一条指向R2,指向R2的路由metric设大些。同样R2也是类似的配法。这样家属用R1,办公用R2。R1外线断了,可以走R2。同理R2也是一样。

好想法,利用浮动静态路由互做备份!pix上只做个nat,做几条静态路由,分别指向r1和r2,策列有65完成,不过实施起来有难度哦

zl5enter 2006-03-31 11:15

回复: 【求助】双出口+策略路由+链路互备
 
65上:
e0/0:ip address 10.10.0.254 255.255.255.0
e0/1: ip address 10.10.1.254 255.255.255.0
vlan 1 (management)
10.10.100.253 255.255.255.0
vlan 10
10.10.0.253 255.255.255.0
vlan 20
ip address 10.10.1.1 255.255.255.0

ip routing

26-1:
e0/0:
ip address 10.10.0.2 255.255.255.0
standby 1 ip 10.10.0.1
standby 1 priority 105
standby 1 preempt
standby 2 ip 10.10.10.1
standby 2 preempt

s0/0
ip address 192.168.250.1 255.255.255.252

ip route 0.0.0.0 0.0.0.0 192.168.250.1

26-2:
e0/0:
ip address 10.10.0.3 255.255.255.0
standby 1 preempt
standby 1 ip 10.10.0.1
standby 2 ip 10.10.10.2
standby 2 priority 105 preempt

s0/0:
192.168.248.1 255.255.255.252

ip route 0.0.0.0 0.0.0.0 192.168.248.2

zl5enter 2006-03-31 11:17

回复: 【求助】双出口+策略路由+链路互备
 
好像不对,大家一起改改吧,我大概是这个思路。

sd5193387 2006-03-31 11:35

回复: 【求助】双出口+策略路由+链路互备
 
HSRP 应该可以啊!!!
新手!

liuxuewu21 2006-03-31 11:42

回复: 【求助】双出口+策略路由+链路互备
 
我的想法是两路由器做VRRP或者HSRP 然后连个防火墙(做策略也可以不做也可以)然后交换机 然后两个地方,如果做浮动路由

liuxuewu21 2006-03-31 11:45

回复: 【求助】双出口+策略路由+链路互备
 
我的想法是两路由器做VRRP或者HSRP 然后连个防火墙(做策略也可以不做也可以)然后交换机 然后两个地方,如果一个断了另个马上起来
对接入两个小区分别走两个不同线路那就走浮动路由,
有不对的地方希望指出

liuxuewu21 2006-03-31 11:47

回复: 【求助】双出口+策略路由+链路互备
 
ip access-list 110 permit 192.168.1.0 0.0.0.255 any
ip access-list 100 permit 192.168.2.0 0.0.0.255 any
route-map filter 1 permit 10
match ip interface e0
match ip address 110
set ip next-hop ge0/1(网通)
route-map filter 1 permit 20
match ip interface e1
match ip address 120
set ip next-hop ge0/1(电信)
route-map filter 1 permit 30

ip local policy-map route-map filter
假设E0对应的网络是网通的:192.168.1.0
假设E1对应的网络是电信的:192.168.2.0
我做过实验在同台路由器上可以做的

yelangdy 2006-03-31 15:04

回复: 【求助】双出口+策略路由+链路互备
 
感谢大家的回复。问提是:6楼的方法可行,但PIX不能升级。无法支持透明模式。
11楼的方法。无法实现切换

yelangdy 2006-03-31 15:09

回复: 【求助】双出口+策略路由+链路互备
 
各位大虾们有没有更好的方法??

ponecn 2006-03-31 16:22

回复: 【求助】双出口+策略路由+链路互备
 
关注


所有时间均为北京时间。现在的时间是 05:40

Powered by vBulletin® 版本 3.8.3
版权所有 ©2000 - 2018,Jelsoft Enterprises Ltd.
增强包 [3.4] 制作: PHP源动力   官方中文站: vBulletin 中文
Copyright © 2003 - 2013 Net130.com, All Rights Reserved 备案号:皖ICP备11007528号